lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yannick Alméras <yalme...@gmail.com>
Subject Re: Error when merging segments ("terms out of order")
Date Wed, 08 May 2019 19:38:31 GMT
Hello,

I installed it with the openjdk-11-jdk package from Ubuntu 18.04 repository with apt-get...


For the moment, no more problem with openjdk-8... I don't know the exact reason of problems
with openjdk-11 32bit (?). 

I will go on a 64bit system when possible (server is installed as 32bit since long time with
many different things on it... That will be a big work). 

Best regards, 
Y. Alméras 



Le 8 mai 2019 21:24:19 GMT+02:00, Shawn Heisey <apache@elyograg.org> a écrit :
>On 5/8/2019 10:47 AM, Alméras Yannick wrote:
>> The problem of segments merging seems to be solved when I replace
>Java 11
>> 32bit with Java 8 32bit on my prod Ubuntu server... (On my dev
>archlinux
>> computer, no problem with Java 11 64bit...).
>
>It is strongly recommended to run a 64-bit version of Java if you can 
>... but it does seem very weird that 32-bit Java would cause that 
>particular issue.
>
>It's not that there's anything inherently wrong with 32-bit software
>... 
>but 32-bit Java can only access 2GB of heap memory, and more is often 
>needed.
>
>I'm curious how you obtained a 32 bit version of Java 11.  Looking at 
>the websites for Oracle Java and OpenJDK, I do not see any way to 
>download it.  Oracle stopped putting 32-bit versions on their public 
>download page with Java 9.
>
>Thanks,
>Shawn

Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message