lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Irfan Nagoo <irfan.na...@ventivtech.com>
Subject Solr 7.7.1 issue: TemplateTransformer doesn't take the value of static template attribute value
Date Fri, 03 May 2019 18:08:22 GMT
Hi,

Recently we upgraded our Solr from 5.1 to 7.7.1.  Here is an example of an entity in data-config.xml
to illustrate the issue we are facing:

<entity name="category" query="..." transformer="TemplateTransformer">
    <field name="category_name” column="c_name"   template=”CATEGORY" />
</entity

In Solr 5.1, TemplateTransformer sets the “category_name” with the value of static “template”
attribute (catergory_name: CATEGORY). However, In Solr 7.7.1, TemplateTransformer sets the
“category_name” with the value of database column value (c_name). However, if we change
the name of database column (c_name) to any non-existent name (say x_abc),  TemplateTransformer
sets the “category_name” with the value of “template” attribute.

This inconsistency is causing issues in our application since the TemplateTransformer should
take the value of template attribute in all cases.  Please verify if this is a bug?  Any help
in this regard would be much appreciated.

Thanks, Irfan
IMPORTANT NOTICE: This e-mail message is intended to be received only by persons entitled
to receive the confidential information it may contain. E-mail messages to clients of Ventiv
Technology Inc., may contain information that is confidential and legally privileged. Please
do not read, copy, forward, or store this message unless you are an intended recipient of
it. If you have received this message in error, please forward it to the sender and delete
it completely from your computer system.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message