lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From स्वप्निल रोकडे <swapnil.ro...@gmail.com>
Subject Loosing data on Solr restart
Date Mon, 17 Jun 2019 07:01:56 GMT
I am newbie to Apache Manifold (ver – 2.12) and Solr(ver – 7.6) with
Zookeeper (ver 3.14). I have created three collections in Solr out of which
data for two comes from Manifold while one has from manual data insert
through simple solr API. When I run jobs in Manifold I can see data is
getting inserted in Solr and can be seen by querying Solr.

But when I restart solr all the shards and replicas goes down and do not
recover ever. Also, I am unable to reload the collection as it always gives
timeout error. I tried to take index backup and then try to restore it but
restoring also fails with timeout error. I tried this reload command,
restore command from the same server in which they are installed but still
it fails. Looks like problem is only with the collections in which data is
coming from Manifold as my other collection where I insert data via Solr
API starts properly after restart. I don’t see any error getting logged in
solr logs properly.

I am not getting if I missed anything while doing configurations or there
is some kind of lock on solr due to which none of the reload, restore
commands works properly and on restarting solr I lose everything.

Please suggest.
Regards,
Swapnil

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message