lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexandre Rafalovitch <arafa...@gmail.com>
Subject Re: Error 401 and 404 while Solr product search.
Date Thu, 27 Jun 2019 20:21:55 GMT
Those are two different collections. Have you tried solving the easier
one (non secure), by accessing
/solr/master_doterraUSContent_Index/select in the browser? Seems to be
the collection is not there or named differently. So, that would be
the first step to check.

Regards,
   Alex.

On Thu, 27 Jun 2019 at 16:01, Pratap Pandey <ppandey@doterra.com> wrote:
>
> Hi,
>
>
>
> I am working on upgrading solr to 7.4 along with hybris upgrade to 1808. We are getting
issues while searching for product using Solr search. Below are the details.
>
>
>
> Upgraded Hybris version  : 1808
>
> Upgraded Solr version : 7.4
>
>
>
> Error log snippet:
>
>
>
> [1;31mERROR [hybrisHTTP32] [DoterraErrorsUtil] DoterraErrorsUtil.handleDoterraExcpetion:
>
> [m de.hybris.platform.solrfacetsearch.search.FacetSearchException: Error from server
at https://localhost:8983/solr: Error from server at https://localhost:8983/solr/master_doterraUSContent_Index:
Expected mime type application/octet-stream but got text/html. <html>
>
> <head>
>
> <meta http-equiv="Content-Type" content="text/html;charset=utf-8"/>
>
> <title>Error 404 Not Found</title>
>
> </head>
>
> <body><h2>HTTP ERROR 404</h2>
>
> <p>Problem accessing /solr/master_doterraUSContent_Index/select. Reason:
>
> <pre>    Not Found</pre></p>
>
> </body>
>
> </html>
>
>
>
>         at de.hybris.platform.solrfacetsearch.search.impl.LegacyFacetSearchStrategy.search(LegacyFacetSearchStrategy.java:204)
~[solrfacetsearchserver.jar:?]
>
>         at de.hybris.platform.solrfacetsearch.search.impl.DefaultFacetSearchService.search(DefaultFacetSearchService.java:89)
~[solrfacetsearchserver.jar:?]
>
>         at de.hybris.platform.solrfacetsearch.search.impl.DefaultFacetSearchService.search(DefaultFacetSearchService.java:78)
~[solrfacetsearchserver.jar:?]
>
>
>
>
>
> When using the authentication settings (security.json and authType properties), I am
getting a 401 authentication error. Below is the log snippet:
>
>
>
> [1;31mERROR [hybrisHTTP6] [DoterraErrorsUtil] DoterraErrorsUtil.handleDoterraExcpetion:
>
> [m de.hybris.platform.solrfacetsearch.search.FacetSearchException: Error from server
at https://localhost:8983/solr: Error from server at https://localhost:8983/solr/master_doterraMedia_Index:
Expected mime type application/octet-stream but got text/html. <html>
>
> <head>
>
> <meta http-equiv="Content-Type" content="text/html;charset=utf-8"/>
>
> <title>Error 401 require authentication</title>
>
> </head>
>
> <body><h2>HTTP ERROR 401</h2>
>
> <p>Problem accessing /solr/master_doterraMedia_Index/select. Reason:
>
> <pre>    require authentication</pre></p>
>
> </body>
>
> </html>
>
>
>
>         at de.hybris.platform.solrfacetsearch.search.impl.LegacyFacetSearchStrategy.search(LegacyFacetSearchStrategy.java:204)
~[solrfacetsearchserver.jar:?]
>
>         at de.hybris.platform.solrfacetsearch.search.impl.DefaultFacetSearchService.search(DefaultFacetSearchService.java:89)
~[solrfacetsearchserver.jar:?]
>
>         at de.hybris.platform.solrfacetsearch.search.impl.DefaultFacetSearchService.search(DefaultFacetSearchService.java:78)
~[solrfacetsearchserver.jar:?]
>
>         at com.hybris.doterra.core.search.content.impl.DefaultDoterraContentSearchService.quickSearchContent(DefaultDoterraContentSearchService.java:754)
[classes/:?]
>
>
>
>
>
>
>
> Attached is the complete logs for both scenarios.
>
>
>
>
>
> Can someone please help on this?
>
>
>
>
>
>
>
> Thanks,
>
> Pratap
>
>

Mime
View raw message