lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From varma mahesh <varma.mah...@gmail.com>
Subject Re: Solr slave core corrupted and not replicating.
Date Fri, 07 Jun 2019 09:50:22 GMT
Hi team,

Please help us in the issue mentioned above.
If this is not the right place to look please direct us to the correct
team.

Thanks & Regards,
Y Mahesh Varma

On Thu, 6 Jun, 2019, 1:21 AM varma mahesh, <varma.mahi25@gmail.com> wrote:

> ++solr-user@lucene.apache.org
>
> On Thu 6 Jun, 2019, 1:19 AM varma mahesh, <varma.mahi25@gmail.com> wrote:
>
>> Hi Team,
>>
>>
>> What happens to Sitecore - Solr query handling when a core is corrupted
>> in Solr slave in a Master - slave setup?
>>
>> Our Sitecore site's solr search engine is a master-slave setup. One of
>> the cores of the Slave is corrupted and is not available at all in Slave.
>>
>> It is not being replicated from Master too (Expecting index replication
>> to do this but core is completely missing in Slave). As read in index
>> replication documentation, all the queries are handled by Slave part of the
>> set up.
>>
>> What happens to the queries that are handled by this core that is missing
>> in slave?
>>
>> Will they be taken over by Master?
>>
>> Please help me as I can find no info about this anywhere else. For info
>> the core that is missing is of Sitecore
>> analytics index.
>>
>> The error that Solr slave showing us for Analytics core is:
>>
>> Ojrg.apache.solr.common.SolrException: Error opening new searcher
>>  at org.apache.solr.core.SolrCore.<init>(SolrCore.java:815)
>>   at org.apache.solr.core.SolrCore.<init>(SolrCore.java:658)
>>    at org.apache.solr.core.CoreContainer.create(CoreContainer.java:637)
>>   at org.apache.solr.core.CoreContainer$1.call(CoreContainer.java:381)
>>  at org.apache.solr.core.CoreContainer$1.call(CoreContainer.java:375)
>>         at java.util.concurrent.FutureTask.run(FutureTask.java:262)
>>         at
>> org.apache.solr.common.util.ExecutorUtil$MDCAwareThreadPoolExecutor$1.run(ExecutorUtil.java:148)
>>         at
>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1152)
>>  at
>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:622)
>>   at java.lang.Thread.run(Thread.java:748)
>>
>> Can you please help us here why this happened? We could not find any info
>> from the logs that is leading us to this error.
>>
>>
>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message