lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrzej Białecki ...@getopt.org>
Subject Re: Autoscaling simulation error
Date Sun, 15 Dec 2019 22:12:34 GMT
Could you please provide the exact command-line? It would also help if you could provide an
autoscaling snapshot of the cluster (bin/solr autoscaling -save <snapshotDir>) or at
least the autoscaling diagnostic info.

(Please note that the mailing list removes all attachments, so just provide a link to the
snapshot).


> On 15 Dec 2019, at 18:42, Cao, Li <Li_Cao@comcast.com> wrote:
> 
> Hi!
> 
> I am using solr 8.3.0 in cloud mode. I have collection level autoscaling policy and the
collection name is “entity”. But when I run autoscaling simulation all the steps failed
with this message:
> 
>        "error":{
>          "exception":"java.io.IOException: java.util.concurrent.ExecutionException: org.apache.solr.common.SolrException:
org.apache.solr.common.SolrException: Could not find collection : entity/shards",
>          "suggestion":{
>            "type":"repair",
>            "operation":{
>              "method":"POST",
>              "path":"/c/entity/shards",
>              "command":{"add-replica":{
>                  "shard":"shard2",
>                  "node":"my_node:8983_solr",
>                  "type":"TLOG"}}}},
>          "replicaInfo":null}}},
> 
> Does anyone know how to fix this? Is this a bug?
> 
> Thanks!
> 
> Li


Mime
View raw message