lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Odysci <ody...@gmail.com>
Subject Re: problem using Http2SolrClient with solr 8.3.0
Date Sun, 01 Dec 2019 17:23:32 GMT
That worked. I included the dist/solrj-lib  libs in my class path, and
could make it work with Http2SolrClient. Thanks!

Still on a related topic, is the CloudHttp2SolrClient client fully stable?
(I'm using solr 7.7 and solr 8.3)
Thanks

On Thu, Nov 28, 2019 at 3:00 PM Shawn Heisey <apache@elyograg.org> wrote:

> On 11/28/2019 9:30 AM, Odysci wrote:
> > No, I did nothing specific to Jetty. Should I?
>
> The http/2 Solr client uses a different http client than the previous
> ones do.  It uses the client from Jetty, while the previous clients use
> the one from Apache.
>
> Achieving http/2 with the Apache client would have required using a beta
> release, while the Jetty client has had http/2 in a GA release for three
> years.
>
> The error message you're getting indicates that you have not included
> the Jetty client jar in your project.  Using a dependency manager should
> pull in all required dependencies.  If you're not using a dependency
> manager, you will find all the jars that you need in the dist/solrj-lib
> directory in the Solr download.
>
> Thanks,
> Shawn
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message