lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sudhir kumar <gogikarsud...@gmail.com>
Subject Re: backing up and restoring
Date Thu, 12 Dec 2019 08:49:19 GMT
Hi Rhyhs,

once you backup index with some location, you have to specify the same
location to restore.

ie in your case /tmp/solr is the location indexed was backed up , use same
location for restore.

you did not provide name so latest snapshot will be restored.

curl '
http://localhost:8983/solr/debt/replication?command=backup&location=/tmp/solr
'

snapshot is created at /tmp/solr/snapshot.2019xxxxxxxxxx

execute below command, latest snapshot will be restored
curl '
http://localhost:8983/solr/debt/replication?command=restore&location=/tmp/solr
<http://localhost:8983/solr/debt/replication?command=backup&location=/tmp/solr>
'

below command can be used for details:
curl 'http://localhost:8983/solr/debt/replication?command=details
<http://localhost:8983/solr/debt/replication?command=backup&location=/tmp/solr>
'

for details please refer:
https://lucene.apache.org/solr/guide/6_6/making-and-restoring-backups.html


Thanks,
Sudhir .



On Wed, Dec 11, 2019 at 11:36 PM rhys J <rhysshadow@gmail.com> wrote:

> I made backups with the following command:
>
> sudo -u solr curl '
>
> http://localhost:8983/solr/debt/replication?command=backup&location=/tmp/solr
> <
> http://localhost:8983/solr/gettingstarted/replication?command=backup&location=/tmp/solr
> >
> backups/debt/'
>
> I double checked that I had made the backup, and I had a backup.
>
> To test the restore function, I deleted documents with the following
> command:
>
> sudo -u solr curl http://localhost:8983/solr/debt/update -H "Content-type:
> text/xml" --data-binary '<delete><query>*:*</query></delete>
>
> I stopped and started the service to verify that there are 0 documents in
> the debt core.
>
> Then I ran the following command:
>
> sudo -u solr curl
> '
> http://localhost:8983/solr/debt/replication?command=restore&name=/tmp/solrbackups/debt/snapshot.20191211175715254
> '
>
> response:
>
>  "responseHeader":{
>     "status":0,
>     "QTime":4},
>   "status":"OK"}
>
> Then I went to the web API to check the amount of documents I had on the
> core. It still says 0.
>
> I stopped and started the service to just be sure that that wasn't the
> problem, but it still says there are 0 documents.
>
> Am I missing a step in how i restore a backup?
>
> Thanks,
>
> Rhys
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message