lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: Admin UI core loading fails
Date Thu, 02 Apr 2020 12:39:44 GMT
What do your Solr logs show? My bet is that your mods to the configs somehow caused the reload
to fail too early in the process to be shown in the UI.

Best,
Erick

> On Apr 2, 2020, at 02:50, TK Solr <tksolrml@sonic.net> wrote:
> 
> I'm on Solr 8.3.1 running in non-solrcloud mode.
> 
> When I tried to reload an existing core from Admin UI's "Core Admin" by clicking Reload,
after modifying the core's conf/managed-schema, no error was reported. But the newly added
field type is not shown in the core's Analyzer section.
> 
> I selected Logging from the side bar, I saw errors like this for every core, not just
the core I tried to reload.
> 
> null:java.io.IOException: Unable to find resource 'custom.vm'
>     at org.apache.solr.response.VelocityResponseWriter.getTemplate(VelocityResponseWriter.java:374)
>     at org.apache.solr.response.VelocityResponseWriter.write(VelocityResponseWriter.java:152)
>     at org.apache.solr.response.QueryResponseWriterUtil.writeQueryResponse(QueryResponseWriterUtil.java:65)
>     at org.apache.solr.servlet.HttpSolrCall.writeResponse(HttpSolrCall.java:892)
>     at org.apache.solr.servlet.HttpSolrCall.call(HttpSolrCall.java:594)
>     at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:419)
>     at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:351)
>     at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1602)
>     at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:540)
> 
> I could not find any mention of custom.vm in any files under any core's conf directory.
> 
> I restarted Solr, the core was loaded without an error and I can see the newly added
filed type.
> 
> What could be the cause of these errors that only happens with the Reload button?
> 
> TK
> 
> 

Mime
View raw message