lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Doherty <bulldoz...@hotmail.com>
Subject solr 8.5.0 and autoscaling cluster policy not applying on creation of collection
Date Wed, 01 Apr 2020 05:47:19 GMT
Hello,
I am trying to resolve an issue with setting the autoscaling cluster policy and not having
any luck

I have tried
"set-cluster-policy" : [
{"replica": "#EQUAL","shard": "#EACH","sysprop.zone":"#EACH"}
]}'

And it sets correctly, but doesnt seem to stick to that policy when creating a collection.

I have tried based on ip_2 and also tried a nodeset with no luck.

I have set the sysprop.zone=us-east-1a and 1b for AWS zones they are related to in the solr.in.sh
(SOLR_OPTS) and this shows up in the dashboard

I basically want to just make sure that at least one replica is on each Availability Zone
in AWS

It doesnt seem to matter if i set more shards or more replication factor - i get the same
result.

Below is the full autoscale set i have right now, but i have tried all multiples of below
with sysprop in it each time.


 "cluster-preferences":[
    {
      "minimize":"cores",
      "precision":1},
    {"maximize":"freedisk"}],
  "cluster-policy":[
    {
      "node":"#ANY",
      "replica":"<2",
      "shard":"#EACH"},
    {
      "cores":"#EQUAL",
      "node":"#ANY"},
    {
      "replica":"#EQUAL",
      "shard":"#EACH",
      "sysprop.zone":"#EACH"}],


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message