lucy-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nick Wellnhofer (JIRA)" <j...@apache.org>
Subject [lucy-issues] [jira] [Assigned] (CLOWNFISH-15) Method OFFSET vars should be uint32_t instead of size_t
Date Fri, 17 Apr 2015 19:52:58 GMT

     [ https://issues.apache.org/jira/browse/CLOWNFISH-15?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nick Wellnhofer reassigned CLOWNFISH-15:
----------------------------------------

    Assignee: Nick Wellnhofer

> Method OFFSET vars should be uint32_t instead of size_t
> -------------------------------------------------------
>
>                 Key: CLOWNFISH-15
>                 URL: https://issues.apache.org/jira/browse/CLOWNFISH-15
>             Project: Apache Lucy-Clownfish
>          Issue Type: Improvement
>            Reporter: Marvin Humphrey
>            Assignee: Nick Wellnhofer
>
> To save a little space on 64-bit systems, the global OFFSET variables we use to store
offsets into vtables should be uint32_t instead of size_t.  We'll never need to support so
many methods on a given class that we exceed the capacity of a uint32_t.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message