lucy-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nick Wellnhofer (JIRA)" <j...@apache.org>
Subject [lucy-issues] [jira] [Resolved] (LUCY-287) Mismatch between required Clownfish versions
Date Sat, 06 Feb 2016 15:48:39 GMT

     [ https://issues.apache.org/jira/browse/LUCY-287?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nick Wellnhofer resolved LUCY-287.
----------------------------------
       Resolution: Fixed
    Fix Version/s: 0.4.4
                   0.5.0

Fixed in 0.4 and master.

> Mismatch between required Clownfish versions
> --------------------------------------------
>
>                 Key: LUCY-287
>                 URL: https://issues.apache.org/jira/browse/LUCY-287
>             Project: Lucy
>          Issue Type: Bug
>          Components: Perl bindings
>    Affects Versions: 0.4.1, 0.4.2, 0.4.3
>            Reporter: Nick Wellnhofer
>            Assignee: Nick Wellnhofer
>             Fix For: 0.5.0, 0.4.4
>
>
> In Lucy.cfp, we currently have (0.4 branch):
> {noformat}
>     "prerequisites": {
>         "Clownfish": "v0.4.3"
>     }
> {noformat}
> In Build.PL, we have:
> {noformat}
>     requires           => {
>         'perl'      => '5.8.3',
>         'Clownfish' => undef,
>     },
> {noformat}
> This can cause build failures if a Clownfish version older than 0.4.3 is already installed
(see CPAN Testers). We should either
> * update the CPAN requirement to 0.4.3, or
> * downgrade the CFP requirement to 0.4.0.
> I'm leaning toward the latter solution. API-wise, Lucy 0.4.3 is compatible with Clownfish
0.4.0.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message