lucy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Octavian Rasnita" <>
Subject Re: [lucy-user] [ANNOUNCE] Apache Lucy (incubating) 0.3.0 released
Date Fri, 03 Feb 2012 06:43:42 GMT
From: "Peter Karman" <>

> Greetings,
> The Apache Lucy team is pleased to announce the release of version 0.3.0
> from the Apache Incubator!


I tried to build Lucy under Windows:

#In perl dir:

perl Build.PL

perl Build

Can't locate Clownfish/CFC/ in @INC (@INC contains: clownfish/perl/b
lib/lib clownfish/perl/blib/arch ../clownfish/perl/blib/lib ../clownfish/perl/bl
ib/arch clownfish\perl\blib\lib clownfish\perl\blib\arch ..\clownfish\perl\blib\
lib ..\clownfish\perl\blib\arch buildlib clownfish/perl/blib/lib clownfish/perl/
blib/arch ../clownfish/perl/blib/lib ../clownfish/perl/blib/arch buildlib e:/usr
/site/lib e:/usr/lib .) at buildlib/Lucy/ line 221.

#So I tried to add the Clownfish lib dir:

perl Build distclean

perl -I "E:\lucy\apache-lucy-incubating-0.3.0\apache-lucy-incubating-0.3.0\clownfish\perl\lib"

perl -I "E:\lucy\apache-lucy-incubating-0.3.0\apache-lucy-incubating-0.3.0\clownfish\perl\lib"

error building dll file from '..\src/CFCBindAliases.c' at e:/usr/site/lib/ExtUti
ls/CBuilder/Platform/ line 130, <DATA> line 1.
Finished building Clownfish compiler.
Parsing Clownfish files...
Can't locate loadable object for module Clownfish::CFC in @INC (@INC contains: c
lownfish/perl/blib/lib clownfish/perl/blib/arch ../clownfish/perl/blib/lib ../cl
ownfish/perl/blib/arch clownfish\perl\blib\lib clownfish\perl\blib\arch ..\clown
fish\perl\blib\lib ..\clownfish\perl\blib\arch buildlib E:\lucy\apache-lucy-incu
bating-0.3.0\apache-lucy-incubating-0.3.0\clownfish\perl\lib clownfish/perl/blib
/lib clownfish/perl/blib/arch ../clownfish/perl/blib/lib ../clownfish/perl/blib/
arch buildlib E:\lucy\apache-lucy-incubating-0.3.0\apache-lucy-incubating-0.3.0\
clownfish\perl\lib e:/usr/site/lib e:/usr/lib .) at E:\lucy\apache-lucy-incubati
ng-0.3.0\apache-lucy-incubating-0.3.0\clownfish\perl\lib/Clownfish/ line 2
BEGIN failed--compilation aborted at E:\lucy\apache-lucy-incubating-0.3.0\apache
-lucy-incubating-0.3.0\clownfish\perl\lib/Clownfish/ line 28.
Compilation failed in require at E:\lucy\apache-lucy-incubating-0.3.0\apache-luc
y-incubating-0.3.0\clownfish\perl\lib/Clownfish/CFC/ line 17.
BEGIN failed--compilation aborted at E:\lucy\apache-lucy-incubating-0.3.0\apache
-lucy-incubating-0.3.0\clownfish\perl\lib/Clownfish/CFC/ line 17.
Compilation failed in require at buildlib/Lucy/ line 221.
Can't locate object method "_clear_registry" via package "Clownfish::CFC::Class"
(perhaps you forgot to load "Clownfish::CFC::Class"?) at E:\lucy\apache-lucy-in
line 23.
END failed--call queue aborted at Build line 221.

I was using MS VS6.

Then I tried with the MinGW compiler included with ActivePerl and it worked very well.

Congratulations for the new release!


View raw message