mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Heimel <mhei...@googlemail.com>
Subject Building Mahout
Date Sun, 18 Oct 2009 15:13:41 GMT
Hi all,

I am running into some problems when trying to build a mahout from the
current SVN repository.
I followed the instructions from:
http://cwiki.apache.org/MAHOUT/buildingmahout.html
However, the first command "mvn install" in mahout/trunk aborts after
downloading some stuff and (successfully) running tests with the
following error:

[INFO] [gpg:sign {execution: sign-artifacts}]
GPG Passphrase: *
Reading passphrase from file descriptor 0
gpg: no default secret key
gpg: signing failed
[INFO] ---------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ---------------------------------------------------------------------
[INFO] Exit code: 2

When I rerun maven install with the -e switch I get the following error:

[INFO] ---------------------------------------------------------------------
[INFO] Building Mahout coure
[INFO]      task-segment: [install]
[INFO] ---------------------------------------------------------------------
[INFO] ---------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ---------------------------------------------------------------------
[INFO] 'copy-resources' was specified in an execution, but not found
in the plugin
[INFO] ---------------------------------------------------------------------
[INFO] Trace
org.apache.maven.lifecylce.LifecycleExecutionException:
'copy-resources' was specified in an execution, but not found in the
plugin
            at org.apache.maven.lifecycle.DefaultLifecycleExecutor.bindExecutionToLifecycle(DefaultLifecycleExecutor.java:1359)
            at org.apache.maven.lifecycle.DefaultLifecycleExecutor.bindPluginToLifecycle(DefaultLifecycleExecutor.java:1260)
            at org.apache.maven.lifecycle.DefaultLifecycleExecutor.constructLifecycleMappings(DefaultLifecycleExecutor.java:1004)
            at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:477)
            at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:330)
            at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:291)
            at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:142)
            at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:336)
            at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:129)
            at org.apache.maven.cli.MavenCli.main(MavenCli.java:287)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:597)
            at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
            at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
            at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
            at org.codehaus.classworlds.Launcher.main(Lauhcer.java:375)

I am a bit at loss here... When I remove the ~/.m2 folder, the second
error disappears - however, I have to recompile and retest everything
and then run into the first error again. I also tried running maven
with -Dmaven.jar.sign.skip=true, but this didn't help either :(

The Mahout source is checked out from svn at revison 826431, I use
maven version 2.0.10 (I also tried 2.2.1 with the same result) and the
sun JDK 1.6.0_16.

Thanks,
Max

Mime
View raw message