mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <>
Subject Re: Running mahout on hadoop
Date Thu, 15 Oct 2009 17:38:36 GMT
Yeah you see the same problem I do. If you use the Hadoop 0.20 API here it
fails because something in Hadoop expects 0.19 APIs. Seems like a bug and I
am waiting on a fix.
The other error sound like a Hadoop version mismatch.

It remains required to pass in a list of user ID to recommend for as input,

On Oct 15, 2009 10:27 AM, "jamborta" <> wrote:

thanks. I tried to run it. I have two places to run it. my desktop where I
installed hadoop. it gives me this error:

Exception in thread "main" java.lang.RuntimeException:
java.lang.RuntimeException: class
org.apache.hadoop.mapreduce.lib.output.TextOutputFormat not

and we have a server running where it gives me another error (I guess this
one is becuase this hadoop is an older version 0.18):

       at org.apache.hadoop.mapreduce.Job.setUseNewAPI(

this is what I used to run it:

hadoop-0.20.1/bin/hadoop jar data/mahout-examples-0.2-SNAPSHOT.job -r -n
10 -m data/data/ -f data/data/ -o /output

I'm not sure about what I should put for userIdFile because userids are
already in the dataModelFile, at least that's how your input worked before.

thanks a lot for your help,


View this message in context:

Sent from the Mahout User List mailing list archive at

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message