mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grant Ingersoll <gsing...@apache.org>
Subject Re: Exception in thread "main" org.apache.lucene.index.CorruptIndexException: unrecognized format -3 in file "_b.fnm"
Date Wed, 26 Oct 2011 12:07:51 GMT
I'll update us to 3.4 anyway, since 3.3 has a nasty bug in it.

On Oct 26, 2011, at 2:47 AM, Lance Norskog wrote:

> Yup! The top-level pom.xml file in mahout gives Lucene 3.3 as the
> requested version. You need to either:
> 1) back-rev your Solr to 3.3, OR
> 2) upgrade your Mahout to use Lucene 3.4 instead of 3.3. You may have
> to make some simple changes in the Mahout code which uses Lucene to
> match any API changes, but there should not be any real differences.
> 
> 
> On 10/24/11, Isabel Drost <isabel@apache.org> wrote:
>> On 20.10.2011 OldSkoolMark wrote:
>>> Exception in thread “main” org.apache.lucene.index.CorruptIndexException:
>>> unrecognized format -3 in file “_b.fnm”
>> 
>> Not having much experience with Lucene this looks like you are trying to
>> read
>> the index with Lucene in a version that is older than the one the index was
>> created with?
>> 
>> 
>> Isabel
>> 
> 
> 
> -- 
> Lance Norskog
> goksron@gmail.com

--------------------------------------------
Grant Ingersoll
http://www.lucidimagination.com




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message