mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dhruv <dhru...@gmail.com>
Subject Re: Running a single test
Date Thu, 13 Sep 2012 07:34:12 GMT
Your command is correct, and it should run a single test. I just tried
running a new test I wrote from the $MAHOUT_HOME/core/ directory.

>From where are you firing this command?

On Wed, Sep 12, 2012 at 12:09 PM, Nick Kolegraff <nickkolegraff@gmail.com>wrote:

> Does this work for anyone?
> mvn -Dtest=YourTest install
>
> Doing a bit of practice and trying to understand mahout a bit better
> internally so I wanted to try and implement something basic to get a feel,
> yet, I'm running into some issues.
> /* Disclaimer I'm new to java/maven */
> /* 'mvn install' will find and run the test fine but that got annoying
> pretty quick */
>
> I have the following files:
>
> $MAHOUT_HOME/core/src/main/java/org/apache/mahout/cf/taste/impl/common/HarmonicRunningAverage.java
>
> $MAHOUT_HOME/core/src/test/java/org/apache/mahout/cf/taste/impl/common/HarmonicRunningAverageTest.java
>
> $MAHOUT_HOME/core/target/test-classes/org/apache/mahout/cf/taste/impl/common/HarmonicRunningAverageTest.class
>
> $MAHOUT_HOME/core/target/classes/org/apache/mahout/cf/taste/impl/common/HarmonicRunningAverage.class
>
> However, this:
>    mvn -Dtest=HarmonicRunningAverageTest install
> doesn't seem to work for ANY single test I run and I get this error:
>
>     [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-surefire-plugin:2.11:test (default-test) on
> project mahout-buildtools: No tests were executed!  (Set
> -DfailIfNoTests=false to ignore this error.) -> [Help 1]
>
> Looks like a surefire issue, so I found this:
> http://jira.codehaus.org/browse/SUREFIRE-827
> and changed my version of surefire to 2.12.{1,2} (which should contain the
> fix per the jira ticket) yet the same problem persists.
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-surefire-plugin:2.12.1:test (default-test)
> on project mahout-buildtools: No tests were executed!  (Set
> -DfailIfNoTests=false to ignore this error.) -> [Help 1]
>
> Is this consistent with everyone else or am I missing something trivial?
> How is everyone else running single tests?
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message