mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prajakta Kalmegh <pkalm...@gmail.com>
Subject Mahout With Eclipse problems
Date Fri, 09 Nov 2012 18:13:40 GMT
Hi

I was trying to setup Mahout 0.7 (stable release) and am seeing the
following 2 problems in eclipse.

Plugin execution not covered by lifecycle configuration:
org.apache.maven.plugins:maven-antrun-plugin:1.6:run (execution: default,
phase: compile)
Plugin execution not covered by lifecycle configuration:
org.apache.mahout:mahout-collection-codegen-plugin:1.0:generate (execution:
default, phase: generate-sources)

People have seen this error before too <
http://stackoverflow.com/questions/11282737/errors-when-importing-mahouts-maven-resource-to-eclipse>.
I
see from <https://issues.apache.org/jira/browse/MAHOUT-1043> a patch to
resolve the error in importing Mahout 0.7 in Eclipse IDE, but when I try to
apply this patch on 0.7, it fails.

I also tried checking out Mahout 0.8-SNAPSHOT from trunk as well (github)
and it builds and runs fine as before but when trying to import into
eclipse, it gives a LifeCycleMapping error as follows:
 Scanning error [/home/saplabs/Projects/mahout];
org.eclipse.m2e.core.internal.lifecyclemapping.LifecycleMappingConfigurationException:
Cannot parse lifecycle mapping metadata for maven project MavenProject:
org.apache.mahout:mahout:0.8-SNAPSHOT @
/home/saplabs/Projects/mahout/pom.xml Cause: Unrecognised tag: 'version'
(position: START_TAG seen ...</artifactId>\n        <version>... @8:18)

I am using Eclipse Indigo (3.7.2) with M2Eclipse plugin (version 1.0).

Any idea on how to get rid of either the first or 2nd error? Any help will
be really appreciated.

Regards,
Prajakta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message