mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Suneel Marthi <suneel_mar...@yahoo.com>
Subject Re: Mahout Web Service GlassFish 4 Deployment Error
Date Wed, 04 Dec 2013 17:04:19 GMT
Thinking loud here.

Mahout's still using servlet 2.5 and jsp 2.1 api (from what's in the pom today), may be its
time to upgrade to be JEE 6 compliant - viz. support servlet 3.x and jsp 2.2. 

Looking at the web.xml, it still refers to web app 2.3 DTD; which could be the reason for
the CDI deployment failure on Glassfish 4.

{Code}

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
        "http://java.sun.com/dtd/web-app_2_3.dtd">

{Code}


It would be a welcome contribution if somebody volunteers to fix this and bring Mahout to
JEE 6 standards.






On Wednesday, December 4, 2013 11:33 AM, Mario Levitin <mariolevitin@gmail.com> wrote:
 
Hi Manuel, thank you for both of your answers.
I have checked your dacebook-recommender-demo, it uses GlassFish 3, my
problem occurs with GlassFish 4.




On Tue, Dec 3, 2013 at 9:23 PM, Manuel Blechschmidt <
Manuel.Blechschmidt@gmx.de> wrote:

> The following project might help:
>
> https://github.com/ManuelB/facebook-recommender-demo
>
> If you need more support I would recommend to contact one of
 the
> supporting companies like MapF, Cloudera or Apaxo (my own company).
>
> /Manuel
>
> On 02.12.2013, at 22:49, Mario Levitin wrote:
>
> > Hi,
> > I'm trying to build a web service for Mahout.
> > If I use GlassFish 3.x there is no problem. However, when I change to
> > GlassFish 4, during deployment the following error occurs: (by the way,
> > GlassFish 4 works fine for my other web service implementations, my
> > suspicion is that there is some inconsistency between GlassFish 4 and the
> > dependencies needed for Mahout)
> >
> > SEVERE:   Exception during lifecycle processing
> >
 org.glassfish.deployment.common.DeploymentException: CDI deployment
> > failure:WELD-001408 Unsatisfied dependencies for type [Set<Service>] with
> > qualifiers [@Default] at injection point [[BackedAnnotatedParameter]
> > Parameter 1 of [BackedAnnotatedConstructor] @Inject
> > com.google.common.util.concurrent.ServiceManager(Set<Service>)]
> > Any help will be greatly appreciated.
>
> --
> Manuel Blechschmidt
> M.Sc. IT Systems Engineering
> Dortustr. 57
> 14467 Potsdam
> Mobil: 0173/6322621
> Twitter: http://twitter.com/Manuel_B
>
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message