mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lewis John Mcgibbney <lewis.mcgibb...@gmail.com>
Subject Re: Replacement for DefaultAnalyzer
Date Sat, 09 May 2015 14:51:19 GMT
Hi Suneel,
Yes this is true. It was dropped exactly due to the Lucene upgrade.
I'm still working on understanding what to use as the underlying Analyzer
interface from Lucene also dropped the Definition of reusableTokenStream
method call!
Is there any other advice to hand with what to suggest is suitable for
making the upgrade.
The project I am working on is using Hadoop 1.2.X and will not be upgrading
for a while. mahout 0.9 would work perfectly well with this distro however
upgrade is slightly so fusing right now based on the API being broken as
oppose to deprecated.
Thanks again for any help.
Lewis

On Saturday, May 9, 2015, Suneel Marthi <smarthi@apache.org> wrote:

> Not sure how this was used in 0.7 (its > 3 yrs legacy). But I am guessing
> this would have been required for Lucene 3x back then and must have been
> dropped for the Lucene 4x upgrade for 0.8 (circa late 2012).
>
> On Fri, May 8, 2015 at 8:03 PM, Lewis John Mcgibbney <
> lewis.mcgibbney@gmail.com <javascript:;>> wrote:
>
> > Hi Folks,
> > I'm making an upgrade from Mahout 0.7 --> 0.9.
> > I am experiencing the same problem as experienced in the following post
> > [0].
> > Can someone please suggest what I should replace DefaultAnalyzer with? I
> am
> > aware that it was removed from the Mahout API in 0.8?
> > In the meantime I am going to tst an implementation of Lucene's base
> > implementation for the Lucene version matching Mahout 0.9.
> > Thanks in advance to anyone who has the context here.
> > Best
> > Lewis
> >
> > [0] http://www.mail-archive.com/user%40mahout.apache.org/msg14344.html
> >
> > --
> > *Lewis*
> >
>


-- 
*Lewis*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message