mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Re: Error with web service call
Date Wed, 10 Feb 2016 22:34:01 GMT

After all I solved my problem. It was because I had multiple bindings and I don’t know why
the error is launched just when the web service is executed. 

Now I have the following error:

java.lang.UnsupportedOperationException: Not implemented by the DistributedFileSystem FileSystem

I thought it was for the configuration. I tried to run with the API of hadoop and with a native
cluster conf.set("fs.defaultFS", "hdfs://”). I just have problems when
I try to execute through my ws. The difference between my configurations are the class loaders
(LauncherClassLoader for my app and WebAppClassLoader for my ws). I don’t know why it s


> On Feb 10, 2016, at 11:11, FRANCISCO XAVIER SUMBA TORAL <>
> Hi,
> I have built a workflow for clustering. I’d like to execute my workflow and show some
files that the ws returned me back. I can execute with out problems my workflow in my local
machine, but when I want to execute through my ws I got the following error message:
> Warning:   StandardWrapperValve[edu.ucuenca.kodar.webservice.ApplicationConfig]: Servlet.service()
for servlet edu.ucuenca.kodar.webservice.ApplicationConfig threw exception
> java.lang.NoClassDefFoundError: Could not initialize class org.apache.hadoop.conf.Configuration
> I don’t why it is happening. I thought It was for the classpath, but I added to my
client ws all the dependencies of mahout. The error sills. Could anyone help me?
> Cheers.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message