manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <karl.wri...@nokia.com>
Subject RE: java.lang.NullPointerException while trying to crawl RSS feed to Solr
Date Wed, 21 Jul 2010 13:42:52 GMT
That error indicates that there was a Solr exception processing your document.  Can you post
the Solr exception here?

Karl


From: ext Jens Bengtsson [mailto:jens.bengtsson@findwise.se]
Sent: Wednesday, July 21, 2010 9:36 AM
To: connectors-user@incubator.apache.org
Subject: RE: java.lang.NullPointerException while trying to crawl RSS feed to Solr

So I updated and this is the error I get in the log now:

Service interruption reported for job 1279719088042 connection 'Giantbomb RSS': Error 500
from ingestion request; ingestion will be retried again later

From: Jens Bengtsson [mailto:jens.bengtsson@findwise.se]
Sent: den 21 juli 2010 14:41
To: connectors-user@incubator.apache.org
Subject: RE: java.lang.NullPointerException while trying to crawl RSS feed to Solr

No worries!

I'm very thankful for your help.

Jens

From: karl.wright@nokia.com [mailto:karl.wright@nokia.com]
Sent: den 21 juli 2010 14:34
To: connectors-user@incubator.apache.org
Subject: RE: java.lang.NullPointerException while trying to crawl RSS feed to Solr

Yesterday should be fine.  I overlooked something and have checked in a fix.  My apologies.

Karl



From: ext Jens Bengtsson [mailto:jens.bengtsson@findwise.se]
Sent: Wednesday, July 21, 2010 8:26 AM
To: connectors-user@incubator.apache.org
Subject: RE: java.lang.NullPointerException while trying to crawl RSS feed to Solr

That's strange because I did the checkout from https://svn.apache.org/repos/asf/incubator/lcf/trunk
yesterday and I did a update today and rebuilt everything so things should be in sync with
trunk.

Jens

From: karl.wright@nokia.com [mailto:karl.wright@nokia.com]
Sent: den 21 juli 2010 13:55
To: connectors-user@incubator.apache.org
Subject: RE: java.lang.NullPointerException while trying to crawl RSS feed to Solr

Hi Jens,

The trace you gave me is out of date wrt trunk by at least a month.  Would you be willing
to synch up to the latest LCF, and see how you do with that?  If you still see a trace, I'd
be happy to analyze it and perhaps check in a patch.

Karl


From: Wright Karl (Nokia-MS/Cambridge)
Sent: Wednesday, July 21, 2010 6:51 AM
To: jens.bengtsson@findwise.se; connectors-user@incubator.apache.org
Subject: RE: java.lang.NullPointerException while trying to crawl RSS feed to Solr


The 'connection working' from rss doesn't mean much.  But the 'connection working' from solr
means that lcf could talk to solr and do a ping.



In any case, you should never see an NPE from lcf, so I am going to look into this at earliest
opportunity.  It is possible that the NPE is masking some other error, but maybe it is just
broken.



Karl



--- original message ---

From: "ext Jens Bengtsson" <jens.bengtsson@findwise.se>

Subject: java.lang.NullPointerException while trying to crawl RSS feed to Solr

Date: July 21, 2010

Time: 6:38:7  AM


Hi!

I have setup a connector against a RSS-feed with output to a Solr server. The repository connection
and output connection report that the connection is ok.

When I run the job it seems to retrieve the RSS feed and process everything as it should,
the data does not seem to get indexed into Solr however.

If I look in the lcf log file I find the following:
Error tossed: null
java.lang.NullPointerException
                             at org.apache.lcf.agents.output.solr.HttpPoster$IngestThread.run(HttpPoster.java:976)

I guess there's an error when it tries to post the data to Solr, but I can't figure out what
the problem is. If I look at the catalina log for the tomcat where Solr is run I can't find
any errors or anything else.

Does anyone have any tips?


Mime
View raw message