manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: Problem connecting to Solr 3.5
Date Tue, 06 Dec 2011 22:11:12 GMT
Are you sure you set the job up with the Solr output connection as the
output?  It sounds like it might be going to a null output connection
or some such.  Alternatively, there are a number of ways you can
filter out documents from your crawl which you may have set
incorrectly.  For example, the document exclusion/inclusion tabs in
the web job also have indexing inclusion/exclusion fields; if those
regexps are not correct you may wind up discarding everything you
crawl.

There is also a Documents tab in your Solr connection configuration
that allows you to filter documents indexed by Solr by mime type.
Make sure the mime types you are interested in are in the list, OR
make sure the list is empty.

FWIW, if you mess up configuration with the Solr connector, it is
*not* silent.  You'd see errors all over the place.  So that's
probably not the issue.

Karl

On Tue, Dec 6, 2011 at 4:37 PM, Michael Kelleher <mj.kelleher@gmail.com> wrote:
> I have a Solr output connector setup:
>    server settings:
>        http
>        localhost
>        8983
>
>        solr
> <my core name here>
>        /update/extract
>        /update
>        /admin/ping
>
>        everything else blank
>
>    Schema
>        id
>
>    All other tabs/configurations are empty
>
>    Solr does indeed have /update and /update/extract configured.
>
>
> After MCF visits the documents, they never get submitted to Solr.  There are
> no exceptions in the log, and there is no activity on the Solr side either.
>
> I am positive I must have missed/configured something wrong, but not sure
> what.
>
> Is anyone else using MCF 0.3 with Solr 3.5?

Mime
View raw message