manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: Cannot find OracleDriver
Date Thu, 19 Jan 2012 20:33:13 GMT
The ticket for this problem is CONNECTORS-390.

Karl

On Thu, Jan 19, 2012 at 3:05 PM, Matthew Parker
<mparker@apogeeintegration.com> wrote:
> Many thanks. I'll give that a try.
>
> On Thu, Jan 19, 2012 at 3:01 PM, Karl Wright <daddywri@gmail.com> wrote:
>>
>> The problem is that the JDBC driver is using a pool driver that is in
>> common with the core of ManifoldCF.  So the connector-lib path, which
>> only the connectors know about, won't do.  That's a bug which I'll
>> create a ticket for.
>>
>> A temporary fix, which is slightly involved, requires you to put the
>> ojdbc6.jar in the example/lib area, as you already tried, but in
>> addition you will need to explicitly include the jar in your
>> classpath.  Normally the start.jar's manifest describes all the jars
>> in the initial classpath.  I thought it was possible to also include
>> additional classpath info through the normal --classpath mechanism,
>> but that doesn't seem to work, so you may be stuck with modifying the
>> root build.xml file to add the jar to the manifest.
>>
>> I'm going to experiment a bit and see if I can come up with something
>> quickly.
>>
>> Karl
>>
>>
>> On Thu, Jan 19, 2012 at 2:48 PM, Karl Wright <daddywri@gmail.com> wrote:
>> > I was able to reproduce the problem.  I'll get back to you when I
>> > figure out what the issue is.
>> > Karl
>> >
>> > On Thu, Jan 19, 2012 at 2:47 PM, Matthew Parker
>> > <mparker@apogeeintegration.com> wrote:
>> >> I've used the jar file in NetBeans to connect to the database without
>> >> any
>> >> issue.
>> >>
>> >> Seems more like a class loader issue.
>> >>
>> >>
>> >> On Thu, Jan 19, 2012 at 2:41 PM, Matthew Parker
>> >> <mparker@apogeeintegration.com> wrote:
>> >>>
>> >>> I have the latest release from the Apache Manifold site (i.e.
>> >>> 0.3-incubating).
>> >>>
>> >>> I checked the driver jar file with winzip, and the driver name is
>> >>> still
>> >>> the same (oracle.jdbc.OracleDriver).
>> >>>
>> >>> I'm running java 1.6.0_18-b7 on Windows XP SP 3.
>> >>>
>> >>> On Thu, Jan 19, 2012 at 2:27 PM, Karl Wright <daddywri@gmail.com>
>> >>> wrote:
>> >>>>
>> >>>> MCF's Oracle support was written against earlier versions of the
>> >>>> Oracle driver.  It is possible that they have changed the driver
>> >>>> class.  If the driver winds up in the dist/connector-lib directory
>> >>>> (I'm assuming you are using trunk or 0.4-incubating), then it should
>> >>>> be accessible.
>> >>>>
>> >>>> Could you please try the following:
>> >>>>
>> >>>> jar -tf ojdbc6.jar | grep "oracle/jdbc/OracleDriver"
>> >>>>
>> >>>> ... assuming you are using Linux?
>> >>>>
>> >>>> If the driver class IS found, then the other possibility is that
the
>> >>>> jar is compiled against a later version of Java than the one you
are
>> >>>> using to run MCF.
>> >>>>
>> >>>> Please let me know what you find.
>> >>>>
>> >>>> Karl
>> >>>>
>> >>>> On Thu, Jan 19, 2012 at 1:43 PM, Matthew Parker
>> >>>> <mparker@apogeeintegration.com> wrote:
>> >>>> > I downloaded MCF and started playing with the default setup
under
>> >>>> > Jetty
>> >>>> > and
>> >>>> > Derby. It starts up without any issue.
>> >>>> >
>> >>>> > I would like to connect to our ORACLE database and import data
into
>> >>>> > SOLR.
>> >>>> >
>> >>>> > I placed the ojdbc6.jar file in the connectors/jdbc/jdbc-drivers
>> >>>> > directory
>> >>>> > as stated in the README instruction file to use the ORACLE
driver.
>> >>>> >
>> >>>> > I ran "ant build" from the main directory, and restarted the
>> >>>> > example in
>> >>>> > dist/example using Jetty.
>> >>>> >
>> >>>> > When I setup a connector, MCF throws an exception stating that
it
>> >>>> > cannot
>> >>>> > find oracle.jdbc.OracleDriver class.
>> >>>> >
>> >>>> > Looking in the connector-lib directory, the oracle jar is there.
>> >>>> >
>> >>>> > I also tried placing the ojdbc6.jar in the dist/example/lib
>> >>>> > directory,
>> >>>> > but
>> >>>> > that didn't fix the problem either.
>> >>>> >
>> >>>> > Can anyone point me in the right direction?
>> >>>> >
>> >>>> > TIA
>> >>>> >
>> >>>> > ------------------------------
>> >>>> > This e-mail and any files transmitted with it may be proprietary.
>> >>>> >  Please
>> >>>> > note that any views or opinions presented in this e-mail are
solely
>> >>>> > those of
>> >>>> > the author and do not necessarily represent those of Apogee
>> >>>> > Integration.
>> >>>> >
>> >>>
>> >> ------------------------------
>> >> This e-mail and any files transmitted with it may be proprietary.
>> >>  Please
>> >> note that any views or opinions presented in this e-mail are solely
>> >> those of
>> >> the author and do not necessarily represent those of Apogee
>> >> Integration.
>> >>
>
>
>
>
>
> ------------------------------
> This e-mail and any files transmitted with it may be proprietary.  Please
> note that any views or opinions presented in this e-mail are solely those of
> the author and do not necessarily represent those of Apogee Integration.
>

Mime
View raw message