manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nigel Thomas <>
Subject Re: Building ManifoldCF 0.6 with Oracle drivers
Date Fri, 21 Sep 2012 14:09:28 GMT
Thanks Karl for point this out.

It may be helpful to change the documentation slightly at


*EITHER:* overlay the lib directory from the corresponding lib distribution
(preferred), *OR* run "ant make-core-deps" to build the code dependencies.


*EITHER:* overlay the lib directory from the corresponding lib
*OR* run "ant make-core-deps" to build the code dependencies.

If you think it appropriate to help reduce ambiguity.

Nigel Thomas
Web Services Group
IT Services
t: 3808

On 21 September 2012 14:49, Karl Wright <> wrote:
> Hi Nigel,
> If you are building trunk, you have to run this ant command:
> ant make-core-deps
> If you are building a released version, which you are, then you must
> download the corresponding apache-manifoldcf-xxx-lib distribution,
> unpack it, and place the contents in the lib directory underneath the
> root level.  If you have done that properly it you should have a build
> area root directory that looks something like this:
> lib
> framework
> connectors
> ...
> The lib directory should contain many jars, including fop.jar, if you
> have done this properly.
> Karl
> On Fri, Sep 21, 2012 at 9:13 AM, Nigel Thomas <>
>> Hello,
>> This is my first attempt at building ManifoldCF, the experience is a
>> little painful at present, I am trying to build a 0.6 from source with
>> Oracle drivers. I followed the instructions here
>> Initially I copied lib binaries from example/lib in
>> apache-manifoldcf-0.6 binary distribution. Am I overlaying the wrong
>> lib directory?
>> On my first attempt to build, the build failed (despite the build
>> successful message) with the stdout "Overlay -lib package, or run
>> 'make-core-deps' target first", the build created dist directory and
>> empty directories for example etc. This is misleading, could the build
>> fail instead of passing?
>> I narrowed build failure down to missing fop.jar, I downloaded this
>> and reran the build this time it failed with
>> "java.lang.ClassNotFoundException:
>> org.apache.taglibs.standard.tlv.JstlCoreTLV"
>> At this point I tried downloading jstl.jar and added this, reran build
>> which failed with the same message.
>> Instead of downloading each dependency individually, I tried
>> downloading dependencies by running make-core-deps, this failed on
>> download-xerces step, commented this out and re ran, this time it
>> failed on download-commons (svn patch is absent on version < 1.7),
>> commented this out and re-ran, this finally ran successfully.
>> Is there a easier way to build from source with all dependencies?
>> Cheers,
>> Nigel Thomas
>> Web Services Group
>> IT Services
>> e:
>> t: 3808

View raw message