manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian M. Rieck" <christian.ri...@comperiosearch.com>
Subject RE: How to fix: 'Driver class not found: net.sourceforge.jtds.jdbc.Driver'
Date Wed, 17 Apr 2013 14:46:37 GMT
Hi Karl,

Using example-proprietary and not example did the trick. That was a bit embarrassing.

By the way (don't know if this belongs here or not)  when compiling I had to point the alfredo-related
things in build.xml from head to http://svn.alfresco.com/repos/alfresco-open-mirror/alfresco/COMMUNITYTAGS/V4.2c/root/projects/3rd-party/lib/
in order to find the jars to download.

Thanks!

Christian.


From: Karl Wright [mailto:daddywri@gmail.com]
Sent: 17. april 2013 16:16
To: user@manifoldcf.apache.org
Subject: Re: How to fix: 'Driver class not found: net.sourceforge.jtds.jdbc.Driver'

Hi Christian,

You definitely must build locally for this driver to be included in the war files etc.  You
must also build using ant, not maven.  The procedure for building is:
(1) ant make-core-deps
(2) ant make-deps
(3) ant build
(4) cd dist/example-proprietary
(5) <java> -jar start.jar
Is this the process you are following?  If not, can you try it this way?
If this doesn't work for you, I'll need to do further research, but I won't be able to do
that until later this evening.
Karl

The jtds version this was last tested with was jtds 1.2.2.

On Wed, Apr 17, 2013 at 9:41 AM, Christian M. Rieck <christian.rieck@comperiosearch.com<mailto:christian.rieck@comperiosearch.com>>
wrote:
Hi all,

I am having problems with ManifoldCF and the MS SQL connector. No matter what I do I get a
"Threw exception: 'Driver class not found: net.sourceforge.jtds.jdbc.Driver'" as connection
status. I have tried building manifold locally  and downloading the binary version but nothing
seems to help.  I have also tried to place the jtds.jar file in connector-lib , connector-lib-proprietary,
example\lib , using jtds-1.3 , jtds-1.2 and the jtds.jar that ant make-deps gets for me. Both
java 1.6.0_45 and 1.7.0_17 have been tried. All attempts have been made with the example application.
The problem is on both Windows8 and Windows Server 2008 R2. Starting manifold and specifying
jtds in the classpath directly doesn't help.

The only time ManifoldCF acknowledged the existence of the Driver-class at all was when I
used jtds-1.3.jar with java 1.6. Since jtds 1.3 requires java 7 I got an exception in the
command window complaining about an unsupported class version:

WARN org.eclipse.jetty.servlet.ServletHandler - /mcf-crawler-ui/viewconnection.jsp
javax.servlet.ServletException: java.lang.UnsupportedClassVersionError: net/sourceforge/jtds/jdbc/Driver
: Unsupported major.minor version 51.0
        [....]
        at org.apache.manifoldcf.crawler.connectors.jdbc.JDBCConnection$TestConnectionThread.run(JDBCConnection.java:233)

The missing driver exception has not been seen in any logs so far.

While looking for the class I installed visualvm and tried to look around. After restarting
manifoldcf a heapdump shows no signs of jtds.jdbc.Driver , after viewing the jdbc-connector
and getting a "driver class not found" exception a new heapdump shows jtds.jdbc.Driver , 1
instance and size 16. That is the closest I got to the class.

I am now giving up and sorely need help.


Regards,
Christian.


Mime
View raw message