manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From altaf a <altaf...@gmail.com>
Subject Sharepoint 2010 connector getting started--facing problem in displaying fields.
Date Thu, 04 Apr 2013 13:13:23 GMT
Hi,

I am very new to SOLR as well as the manifold connector for sharepoint 2010,
I have followed the *
http://manifoldcf.apache.org/release/release-1.1.1/en_US/how-to-build-and-deploy.html
* to configure the connection.

I have configured and declared two fields of sharepoint where xyz and test2
are internal names of columns in SharePoint page library and mapped same
thing in List all jobs-->solr field mapping with xyz-->xyz and
test2-->test2 where xyz and test2 are column names in pages library.

Schema.xml:
<field name="xyz" type="string" indexed="true" stored="true" />
   <field name="test2" type="string" indexed="true" stored="true" />

<field name="allow_token_document" type="string" indexed="true"
stored="false" multiValued="true" required="false"
default="__nosecurity__"/>
   <field name="allow_token_share" type="string" indexed="true"
stored="false" multiValued="true" required="false"
default="__nosecurity__"/>
   <field name="deny_token_document" type="string" indexed="true"
stored="false" multiValued="true" required="false"
default="__nosecurity__"/>
   <field name="deny_token_share" type="string" indexed="true"
stored="false" multiValued="true" required="false"
default="__nosecurity__"/>

I have not removed any other default configurations of this file.


In solrconfig

i have added this in in select request handler

<lst name="appends">
      <str name="fq">{!manifoldCFSecurity}</str>
    </lst>

Now the problem is after successfull crawling , when i am sending a request
to solr as http://localhost:8983/solr/select?q=*:* but the two fields are
not appearing in any of the results where as some fields like title and
content are displaying the values.

Can you please let me know whether i am missing any configuration?? As i am
new i not well aware of specific logging to check .I tried to go thought
the mail archive but didnt find any similar issue . Can anyone please guide
me..

Regards,
Altaf

Mime
View raw message