manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From altaf a <altaf...@gmail.com>
Subject Re: Sharepoint 2010 connector getting started--facing problem in displaying fields.
Date Mon, 15 Apr 2013 09:09:21 GMT
Thanks Karl !!!, I will move this question to solr forms.

Regards,
Altaf.
On Tue, Apr 9, 2013 at 3:49 PM, Karl Wright <daddywri@gmail.com> wrote:

> Yes, that means that your problem is not ManifoldCF configuration at this
> point, but rather Solr.
>
> Karl
>
>
> On Tue, Apr 9, 2013 at 3:41 AM, altaf a <altaff4u@gmail.com> wrote:
>
>>
>> Yes Karl,
>> I am able to see all the properties are getting extracted.in INFO .I am
>> able to see all the properties declared are showing up values in console. I
>> guess it means extraction is happening perfectly but not showing up in  L
>> ocalhost:8983/solr/select?q=*:*
>>
>> Regards,
>> Altaf
>>
>> On Mon, Apr 8, 2013 at 7:24 PM, Karl Wright <daddywri@gmail.com> wrote:
>>
>>>  Usually when you run Solr under Jetty, with the default example
>>> configuration, you will see an INFO message output to standard out or
>>> standard error (the console) on every index post.  That is what I am
>>> referring to.
>>>
>>> Karl
>>>
>>>
>>>
>>> On Mon, Apr 8, 2013 at 9:47 AM, altaf a <altaff4u@gmail.com> wrote:
>>>
>>>> I have placed the below things in
>>>> D:\Slr\solr-4.2.0\solr-4.2.0\example\solr\collection1\conf\schema.xml
>>>> .I dont see any issue in this. Am i missing anything?
>>>> Solr INFO messages : (Can you please let me know where exactly i can
>>>> see the messages regarding metadata extraction)
>>>>
>>>> In this location i have seen logs
>>>> "D:\Slr\solr-4.2.0\solr-4.2.0\example\solr\collection1\data\tlog" but didnt
>>>> get any useful info anywhere else i need to check.
>>>>
>>>> I am using jetty only.
>>>>
>>>> <
>>>> field name="xyz" type="string" indexed="true" stored="true" />
>>>>
>>>> <
>>>> field name="test" type="string" indexed="true" stored="true" />
>>>> Regards,
>>>> Altaf.
>>>>  On Mon, Apr 8, 2013 at 7:00 PM, Karl Wright <daddywri@gmail.com>wrote:
>>>>
>>>>>  It sounds like you are almost there.  I would check the Solr INFO
>>>>> messages to see which attributes are being sent, and which are not. 
I
>>>>> would also check your Solr schema.xml to make sure all the properties
you
>>>>> want are listed and properly spelled.
>>>>>
>>>>> Karl
>>>>>
>>>>>
>>>>> On Mon, Apr 8, 2013 at 9:20 AM, altaf a <altaff4u@gmail.com> wrote:
>>>>>
>>>>>> Hi Karl,
>>>>>>
>>>>>> Did the path change for metadata,reingested and crawled again
>>>>>> I got many successes .Pleae find the below log details ignore the
>>>>>> exact site urls. After this i am able to see the results as i was
able to
>>>>>> previously but the same issue reoccurs ,other propertiesa i am not
able to
>>>>>> see theresults when i search *:* . I am able to get the following
metadata
>>>>>> for all the results when searched
>>>>>> links,title,content,content_type,id,_version_. I am not sure whether
i am
>>>>>> missing any small configuration.
>>>>>>
>>>>>>      45:32.4 document ingest (Test_SP_Slr) http://sites/en-GB.aspx
OK
>>>>>> 87849 92 45:30.4 fetch /Pages//en-GB.aspx Success 90063 2068 45:30.3
document
>>>>>> ingest (Test_SP_Slr) http://sites/_en-GB.aspx OK 89600 75 45:29.8
>>>>>> fetch /Pages//_en-GB.aspx Success 87849 2197
>>>>>>
>>>>>> Regards,
>>>>>> Altaf.
>>>>>>  On Fri, Apr 5, 2013 at 7:30 PM, Karl Wright <daddywri@gmail.com>wrote:
>>>>>>
>>>>>>>  I got the image this time.  My only comment is that the path
match
>>>>>>> does not include a wildcard at the end, and thus it will not
match
>>>>>>> individual list rows.
>>>>>>>
>>>>>>> What I'd like you to do is have a look at the standard output
and
>>>>>>> standard error from Solr from a job run.  Solr by default outputs
an INFO
>>>>>>> statement that describes all the arguments it sees for each indexing
post.
>>>>>>> I want to be sure you are seeing List records being indexed at
all, and
>>>>>>> whether the metadata is being posted there.
>>>>>>>
>>>>>>> In order to force MCF to actually reindex everything in the job,
you
>>>>>>> would want to view the output connection and click the "Reingest
all
>>>>>>> documents" link first.  Then, start the job and watch the output
from
>>>>>>> Solr.  (If you are running Solr under something other than Jetty,
I'm not
>>>>>>> certain where the logging output goes, but you'll need to chase
that down.)
>>>>>>>
>>>>>>> Thanks,
>>>>>>> Karl
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On Fri, Apr 5, 2013 at 9:38 AM, altaf a <altaff4u@gmail.com>
wrote:
>>>>>>>
>>>>>>>> HI Karl,
>>>>>>>>
>>>>>>>> Not sure why its not displaying but please find the same
attached
>>>>>>>> image .
>>>>>>>>
>>>>>>>> Regards,
>>>>>>>> Altaf
>>>>>>>>
>>>>>>>>  On Fri, Apr 5, 2013 at 7:02 PM, Karl Wright <daddywri@gmail.com>wrote:
>>>>>>>>
>>>>>>>>>  Hi Altaf,
>>>>>>>>>
>>>>>>>>> The images are not displaying, I'm afraid. At least google
mail
>>>>>>>>> isn't doing the trick.
>>>>>>>>>
>>>>>>>>> Karl
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> On Fri, Apr 5, 2013 at 9:27 AM, altaf a <altaff4u@gmail.com>wrote:
>>>>>>>>>
>>>>>>>>>>  Hi Karl,
>>>>>>>>>>
>>>>>>>>>> Below is the screen shot of Job and the sharepoint
data is in
>>>>>>>>>> pages library where Xyz,test are the internal names
of the fields in
>>>>>>>>>> sharepoint pages.
>>>>>>>>>>
>>>>>>>>>> *Solr standard output during indexing and see what
arguments it
>>>>>>>>>> is receiving, and whether they match your expectations.*
>>>>>>>>>>
>>>>>>>>>> The above underlined means i need to check in the
manifoldcf
>>>>>>>>>> logs?? I checked there but nothing helped as such.
I am pretty new to solr
>>>>>>>>>> so not sure where to check the standard output of
solr
>>>>>>>>>>
>>>>>>>>>> Can you please let me know if i am missing anything
in the below
>>>>>>>>>> cofiguration.
>>>>>>>>>>
>>>>>>>>>> [image: Inline image 1]
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> On Thu, Apr 4, 2013 at 7:15 PM, Karl Wright <daddywri@gmail.com>wrote:
>>>>>>>>>>
>>>>>>>>>>>  Hi Altaf,
>>>>>>>>>>>
>>>>>>>>>>> The only List attributes that MCF will consider
indexing are the
>>>>>>>>>>> ones that you specify on the job's "Metadata"
tab.  The tab allows you to
>>>>>>>>>>> build rules about what metadata to include in
what context.  See the
>>>>>>>>>>> "end-user-documentation" page for more details
on how to do this and how it
>>>>>>>>>>> works.
>>>>>>>>>>>
>>>>>>>>>>> If you have done this, and you are still having
trouble, it is
>>>>>>>>>>> often helpful to look at the Solr standard output
during indexing and see
>>>>>>>>>>> what arguments it is receiving, and whether they
match your expectations.
>>>>>>>>>>> And if you are STILL stuck after that, you should
post back to this list,
>>>>>>>>>>> but this time include:
>>>>>>>>>>>
>>>>>>>>>>> - a screenshot (or two if necessary) of the "view"
page for your
>>>>>>>>>>> job, so we can see how it is set up, and
>>>>>>>>>>> - a screenshot, or cut-and-paste, of an example
List record
>>>>>>>>>>> being indexed from the Solr standard output
>>>>>>>>>>>
>>>>>>>>>>> Thanks!
>>>>>>>>>>> Karl
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> On Thu, Apr 4, 2013 at 9:13 AM, altaf a <altaff4u@gmail.com>wrote:
>>>>>>>>>>>
>>>>>>>>>>>> Hi,
>>>>>>>>>>>>
>>>>>>>>>>>> I am very new to SOLR as well as the manifold
connector for
>>>>>>>>>>>> sharepoint 2010,
>>>>>>>>>>>> I have followed the *
>>>>>>>>>>>> http://manifoldcf.apache.org/release/release-1.1.1/en_US/how-to-build-and-deploy.html
>>>>>>>>>>>> * to configure the connection.
>>>>>>>>>>>>
>>>>>>>>>>>> I have configured and declared two fields
of sharepoint where
>>>>>>>>>>>> xyz and test2 are internal names of columns
in SharePoint page library and
>>>>>>>>>>>> mapped same thing in List all jobs-->solr
field mapping with xyz-->xyz and
>>>>>>>>>>>> test2-->test2 where xyz and test2 are
column names in pages library.
>>>>>>>>>>>>
>>>>>>>>>>>> Schema.xml:
>>>>>>>>>>>>  <field name="xyz" type="string" indexed="true"
stored="true"
>>>>>>>>>>>> />
>>>>>>>>>>>>    <field name="test2" type="string" indexed="true"
>>>>>>>>>>>> stored="true" />
>>>>>>>>>>>>
>>>>>>>>>>>>  <field name="allow_token_document" type="string"
>>>>>>>>>>>> indexed="true" stored="false" multiValued="true"
required="false"
>>>>>>>>>>>> default="__nosecurity__"/>
>>>>>>>>>>>>    <field name="allow_token_share" type="string"
indexed="true"
>>>>>>>>>>>> stored="false" multiValued="true" required="false"
>>>>>>>>>>>> default="__nosecurity__"/>
>>>>>>>>>>>>    <field name="deny_token_document" type="string"
>>>>>>>>>>>> indexed="true" stored="false" multiValued="true"
required="false"
>>>>>>>>>>>> default="__nosecurity__"/>
>>>>>>>>>>>>    <field name="deny_token_share" type="string"
indexed="true"
>>>>>>>>>>>> stored="false" multiValued="true" required="false"
>>>>>>>>>>>> default="__nosecurity__"/>
>>>>>>>>>>>>
>>>>>>>>>>>> I have not removed any other default configurations
of this
>>>>>>>>>>>> file.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> In solrconfig
>>>>>>>>>>>>
>>>>>>>>>>>> i have added this in in select request handler
>>>>>>>>>>>>
>>>>>>>>>>>>  <lst name="appends">
>>>>>>>>>>>>       <str name="fq">{!manifoldCFSecurity}</str>
>>>>>>>>>>>>     </lst>
>>>>>>>>>>>>
>>>>>>>>>>>> Now the problem is after successfull crawling
, when i am
>>>>>>>>>>>> sending a request to solr as
>>>>>>>>>>>> http://localhost:8983/solr/select?q=*:* but
the two fields are
>>>>>>>>>>>> not appearing in any of the results where
as some fields like title and
>>>>>>>>>>>> content are displaying the values.
>>>>>>>>>>>>
>>>>>>>>>>>> Can you please let me know whether i am missing
any
>>>>>>>>>>>> configuration?? As i am new i not well aware
of specific logging to check
>>>>>>>>>>>> .I tried to go thought the mail archive but
didnt find any similar issue .
>>>>>>>>>>>> Can anyone please guide me..
>>>>>>>>>>>>
>>>>>>>>>>>> Regards,
>>>>>>>>>>>> Altaf
>>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
View raw message