manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Libucha <mlibu...@gmail.com>
Subject postgres stopped working
Date Mon, 04 Nov 2013 18:17:06 GMT
I've been happily running MCF with postgres for several days now, and all
of  a sudden postgres just stopped working. It stopped answering on port
5432. Trying to start it gives me:

LOG:  could not bind IPv4 socket: Cannot assign requested address
HINT:  Is another postmaster already running on port 5432? If not, wait a
few seconds and retry.
WARNING:  could not create listen socket for "localhost"
FATAL:  could not create any TCP/IP sockets

I've done all the expected stuff -- googled it, gone through the
recommended fixes on the postgres site (like trying to start on port 666
instead, but I still get the same error), tried some other random fixes.
Nothing helps.

No postmaster/postgress process is running. Nothing is listening on port
5432 according to netstat. (I'm on CentOS 6.). I've uninstalled and
reinstalled postgres.

I'm guessing there is some sort of resource problem, but the error message
is so incredibly unhelpful, I'm ready to dump postgres and try mysql.

Any suggestions before I do that?

Thanks,

Mark

Mime
View raw message