manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: Parameters question
Date Thu, 12 Dec 2013 01:01:13 GMT
Hi Mark,

When ManifoldCF initially creates a connection, it creates it with an empty
ConfigParams() object.  In the UI, that means that if you see *no*
parameter of the kind you are looking for, you should treat it as if it is
whatever default value you choose.

You are expected to pass the modified data from your ConfigParams object
around in HTML form data.  You "scatter" the data using the
outputConfigurationBody() method, and the processConfigurationPost() method
will be called to collect the data (possibly changed) back into a
ConfigParams object again.  Note that at the time the
processConfigurationPost() method is called, whatever was last saved for
the connection's configuration information initially populates the
ConfigParams object passed  to the post method, so you will want to
overwrite those.

Hope this helps.
Karl



On Wed, Dec 11, 2013 at 6:48 PM, Mark Libucha <mlibucha@gmail.com> wrote:

> Hi,
>
> I'm writing an output connector and can't figure out how to get any
> parameter values other than the default values to display in the webapp.
>
> What is the flow from the agent? When I bring up my connector's tab in the
> Edit Job page, only the output connector's connect() method is being called
> into by the agent, but it's *passing* the config parameters, not asking for
> them.
>
> Where does the agent get them from to begin with? I want to be able to set
> some of the parameters dynamically.
>
> Hope that makes sense.
>
> Thanks,
>
> Mark
>
>

Mime
View raw message