manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Smitha S <Smitha_...@infosys.com>
Subject RE: Help need for connecting to window share
Date Mon, 03 Mar 2014 08:55:23 GMT
Hi Karl,

I am worried that I am not getting your point correctly. May be further explanation from my
side might throw some clarity on the problem which I am facing.

My requirement is to crawl the data resides in a window server. I have made this working by
using the file system repository connection. Please find the steps which I followed below.


1.       Mount the shared folder of windows fileserver to a linux folder using cifs mount
command.

2.       Mount worked successfully and I could access the data in the linux mounted folder.

3.       I have configured filesystem repository connection and while configuring job using
this repository connection, I have given the linux mounted folder in the repository path of
Job UI.

4.       Everything worked well and I could crawl the data by starting the job.

Now I want to perform the crawling using Window File Share repository connection. As per my
understanding ManifoldCF uses the cifs connection to window share. So if I can manually mount
the windows folder in linux, then why I should get an error while configuring window share
using the same server in ManifoldCF.

Could you please throw some light on this. If you could explain the steps involved in configuring
a job using window file server respository it would be great help. Currently I am refereeing
End user documentation for this purpose.

Regards,
Smitha S

From: Karl Wright [mailto:daddywri@gmail.com]
Sent: Monday, March 3, 2014 1:24 PM
To: user@manifoldcf.apache.org
Subject: Re: Help need for connecting to window share

Hi Smitha,
The problem is that, without some research, you may have no idea what server you are actually
talking to, because when you drill down in the Paths tab, you may be traversing DFS nodes
that refer to other servers.  So even though you may be starting at the root talking to a
Windows 2008 Server machine, the path you select may lead you to some other machine.  If you
start out seeing no problem in the UI, but only as you descend to a particular place you run
into issues, that would tend to confirm this story.
Karl

On Mon, Mar 3, 2014 at 2:47 AM, Smitha S <Smitha_S09@infosys.com<mailto:Smitha_S09@infosys.com>>
wrote:
Thanks Karl for the response.

I have my doubts here. I am using windows server 2008  as my repository server. The status
of my repository connection with this window share says "connection working". I hope I get
error in establishing connection if  the issue is due to credentials.

I am getting the error when I go to "PATH" tab of job creation UI. Is there anything extra
I need to do when using Window Share repository connection.

Regards,
Smitha
From: Karl Wright [mailto:daddywri@gmail.com<mailto:daddywri@gmail.com>]
Sent: Monday, March 3, 2014 1:05 PM
To: user@manifoldcf.apache.org<mailto:user@manifoldcf.apache.org>
Cc: user-help@manifoldcf.apache.org<mailto:user-help@manifoldcf.apache.org>
Subject: Re: Help need for connecting to window share

Hi Smitha,

This is apparently a credentials issue.  The error is from the server, and apparently has
to do with smart-card login.  See:

http://support.microsoft.com/kb/891849
and:

http://social.technet.microsoft.com/Forums/windowsserver/en-US/e8cf1a1b-5555-4eaa-b55a-cbfad3ef32d6/error-0xc00000bb-in-smart-card-logon?forum=winserversecurity
If this is an XP system, it means you need SP3 installed.  If this is not an old XP system
that you are crawling, I can find no indication of the circumstances leading to the error.
Karl


On Mon, Mar 3, 2014 at 1:14 AM, Smitha S <Smitha_S09@infosys.com<mailto:Smitha_S09@infosys.com>>
wrote:
Hi,

I am working on a project where I need to use the window file server for crawling documents.
I am trying to use Window Share repository connection.

I could configure the window share repository connection with server details and I managed
to get "Connection Working" status. But while configuring the job using this repository, I
am getting the following error in UI

No starting points defined
SmbException thrown: 0xC00000BB

In the tomcat server console I am getting following exception

org.apache.manifoldcf.core.interfaces.ManifoldCFException: SmbException thrown: 0xC00000BB
        at org.apache.manifoldcf.crawler.connectors.sharedrive.SharedDriveConnector.processSMBException(SharedDriveConnector.java:1289)
        at org.apache.manifoldcf.crawler.connectors.sharedrive.SharedDriveConnector.getChildFolderNames(SharedDriveConnector.java:4703)
        at org.apache.manifoldcf.crawler.connectors.sharedrive.SharedDriveConnector.outputSpecificationBody(SharedDriveConnector.java:3170)
        at org.apache.jsp.editjob_jsp._jspService(editjob_jsp.java:2252)

I am able to perform successful mount with the window fileserver using cifs mount commands
in linux.

Could you please help me with resolving this window share issue. Please let me know if I am
missing anything.

Regards,
Smith

**************** CAUTION - Disclaimer *****************

This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely

for the use of the addressee(s). If you are not the intended recipient, please

notify the sender by e-mail and delete the original message. Further, you are not

to copy, disclose, or distribute this e-mail or its contents to any other person and

any such actions are unlawful. This e-mail may contain viruses. Infosys has taken

every reasonable precaution to minimize this risk, but is not liable for any damage

you may sustain as a result of any virus in this e-mail. You should carry out your

own virus checks before opening the e-mail or attachment. Infosys reserves the

right to monitor and review the content of all messages sent to or from this e-mail

address. Messages sent to or from this e-mail address may be stored on the

Infosys e-mail system.

***INFOSYS******** End of Disclaimer ********INFOSYS***




Mime
View raw message