manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: ManifoldCF 1.6 on Oracle JDK8
Date Sun, 18 May 2014 20:37:20 GMT
I've created a ticket to look at this.  CONNECTORS-938.
Karl


On Sun, May 18, 2014 at 9:10 AM, Ahmet Arslan <iorixxx@yahoo.com> wrote:

> Hi,
>
> If you were using Tomcat setup, I would recommend to update a newer
> version of Tomcat that supports java8.
>
> As I understand this is a servlet container issue, so  we need to upgrade
> embedded jetty version to a version that supports java8.
>
> In mean time, you can use/test/try multi-process installation :
>
>
> http://www.molgun.com/deploying-apache-manifoldcf-to-apache-tomcat-on-ubuntu-server.html
>
>
> http://manifoldcf.apache.org/release/trunk/en_US/how-to-build-and-deploy.html#Command-driven+multi-process+model
>
>
>   On Sunday, May 18, 2014 2:59 PM, Arcadius Ahouansou <
> arcadius@menelic.com> wrote:
>
>
>
> Hi Karl and Ahmet .
>
> I just tried this on windows8 64bit and I am seeing the same issue when I
> try to access the page
> http://localhost:8345/mcf-crawler-ui/documentstatus.jsp
>
> The stack-trace is the same as on Linux (see below)
>
> @Karl: Maybe, your Manifold startup picked up JDK6-7?
>
> @Ahmet:
> I am using the standard download
>
> http://www.apache.org/dyn/closer.cgi/manifoldcf/apache-manifoldcf-1.6-bin.zip
>
> The Jetty version 7.4 in ManifoldCF relies on the Tomcat Jasper JSP
> compiler and the Eclipse ecj.jar Java compiler.
>
> Apparently, ecj.jar is not compatible with the JDK8
>
> There are many discussions about this know issue at :
>
> - https://bugzilla.redhat.com/show_bug.cgi?id=1080026
>
> - https://github.com/processing/processing/issues/2260
> and also
>
> -
> https://support.lucidworks.com/hc/en-us/articles/201784186-Error-in-Javac-compilation-for-JSP-in-LucidWorks-Search-UI
>
>
> *My System:*
>
> C:\>echo %JAVA_HOME%
> c:\Program Files\Java\jdk1.8.0
> C:\>
>
> C:\>java -version
> java version "1.8.0"
> Java(TM) SE Runtime Environment (build 1.8.0-b132)
> Java HotSpot(TM) 64-Bit Server VM (build 25.0-b70, mixed mode)
> C:\>
>
>
> Stacktrace:
> Caused by:org.apache.jasper.JasperException: Unable to compile class for
> JSP:
>
> An error occurred at line: 1 in the generated java file
> The type java.util.Map$Entry cannot be resolved. It is indirectly referenced from required
.class files
>
> Stacktrace:
> 	at org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:92)
> 	at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:330)
> 	at org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:439)
> 	at org.apache.jasper.compiler.Compiler.compile(Compiler.java:356)
> 	at org.apache.jasper.compiler.Compiler.compile(Compiler.java:334)
> 	at org.apache.jasper.compiler.Compiler.compile(Compiler.java:321)
> 	at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:592)
> 	at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:328)
> 	at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
> 	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
> 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
> 	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:547)
> 	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:480)
> 	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
>
>
>
> On 16 May 2014 15:18, Karl Wright <daddywri@gmail.com> wrote:
>
> Hi Arcadius,
>
> I just downloaded the latest JDK 8 (for windows).  It works fine.  I don't
> have a linux setup available, unfortunately, but I think your problem is
> likely to be environment configuration rather than ManifoldCF.
>
> Thanks,
> Karl
>
>
>
> On Fri, May 16, 2014 at 10:14 AM, Karl Wright <daddywri@gmail.com> wrote:
>
> Hmm, it sounds like there may be a missing environment variable on your
> installation.  Do  you have JAVA_HOME set?
>
> Karl
>
>
>
> On Thu, May 15, 2014 at 6:39 PM, Arcadius Ahouansou <arcadius@menelic.com>wrote:
>
>
> Hello.
>
> I am running the official release of ManifoldCF 1.6 on Oracle JDK8 Ubuntu.
>
> I get the error below.
>
> I looks like a JSP compiler compatibility issue with JDK 8?
>
> Thanks.
>
> Arcadius.
>
>
> HTTP ERROR 500
> Problem accessing /mcf-crawler-ui/queuestatus.jsp. Reason:
>     Unable to compile class for JSP:
> An error occurred at line: 1 in the generated java file
> The type java.util.Map$Entry cannot be resolved. It is indirectly
> referenced from required .class files
> Stacktrace:
> Caused by:
>
> org.apache.jasper.JasperException: Unable to compile class for JSP:
>
> An error occurred at line: 1 in the generated java file
> The type java.util.Map$Entry cannot be resolved. It is indirectly
> referenced from required .class files
>
> Stacktrace:
> at
> org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:92)
> at
> org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:330)
>  at
> org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:439)
> at org.apache.jasper.compiler.Compiler.compile(Compiler.java:356)
>
>
>
>
>
>
>
>
>

Mime
View raw message