manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joel Kempista <>
Subject Enable Authority Connections Logging
Date Mon, 01 Dec 2014 15:03:24 GMT
Hi all,
I am working with the JDBC Authority Connection and would like to see
logging when a SQL error occurs, especially syntax errors. I am running
ManifoldCF through Apache Tomcat 7 but I see no logging posted to the
ManifoldCF logs directory or Tomcats own logs. I have configured the
Properties.xml and see logging when I run the start-agents.bat but not from
the services deployed to tomcat.

I tried tuning the logging with properties.xml file and setting an
Authority Connection to a JDBC where the “Authorization Token Query” has a
sql syntax error. When I curl the mcf-authority-service/UserACLs I receive
UNAUTHORIZED for the Auth Connector but when I check the logs I don’t see
why. I expect to see “Authority error: “ + the sql error message but I
don’t see any errors.

  <property name="org.apache.manifoldcf.db" value="DEBUG"/>
  <property name="org.apache.manifoldcf.root" value="DEBUG"/>
  <property name="org.apache.manifoldcf.misc" value="DEBUG"/>
  <property name="org.apache.manifoldcf.lock" value="DEBUG"/>
  <property name="org.apache.manifoldcf.cache" value="DEBUG"/>
  <property name="org.apache.manifoldcf.keystore" value="DEBUG"/>
  <property name="org.apache.manifoldcf.perf" value="DEBUG"/>
  <property name="org.apache.manifoldcf.injest" value="DEBUG"/>
  <property name="org.apache.manifoldcf.api" value="DEBUG"/>
  <property name="org.apache.manifoldcf.threads" value="DEBUG"/>
  <property name="" value="DEBUG"/>
  <property name="org.apache.manifoldcf.hopcount" value="DEBUG"/>
  <property name="org.apache.manifoldcf.scheduling" value="DEBUG"/>
  <property name="org.apache.manifoldcf.authorityservice" value="DEBUG"/>
  <property name="org.apache.manifoldcf.connectors" value="DEBUG"/>
  <property name="org.apache.manifoldcf.authorityconnectors" value="DEBUG"/>
  <property name="org.apache.manifoldcf.agents" value="DEBUG"/>

I don’t need all this logging but ended up turning them on for testing.

Looking at the ManifoldCF it looks like line 102 on
branch dev_1x should produce the error message.

My setup is using the multiprocess-file-example with Apache Tomcat 7.

Anyone know if I am missing a configuration or a setting to enable logging
when deployed to Tomcat?


View raw message