manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Delapasse, Deanna" <>
Subject Question about obtaining metadata values via CMIS connector => ElasticSearch
Date Wed, 06 May 2015 15:42:06 GMT

I'm trying to use ManifoldCF to crawl my Alfresco repo (via the CMIS
connector) and push the results into ElasticSearch.  My users want to
search metadata (including custom) and content. I followed some tutorials
and got it running quickly BUT...regardless of my ElasticSearch mapping the
only CMIS metadata entity I can find in my indexed results is cmis:objectId.

I have tried using various cmis queries (with 'select * ...' and with
'select cmis:name, cmis:lastModifiedBy, ...'.  I have verified my queries
and they definitely return metadata, but the data doesn't appear in
ElasticSearch.   I tried a simple attachment mapping and also a mapping
where I specifically list some of the cmis properties. Regardless of
mapping, my indexes look like this:


The ES results are good and I can search perfectly by content &
cmis:objectId.  I have enabled debugging and no errors appear in the
log.  *What
do I have to DO to get cmis:name, cmis:lastModifiedBy and other properties
to appear?*

Thanks in advance!  This product is very simple to use and has potential to
be a HUGE help to us!!!


View raw message