maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Massol (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MASSEMBLY-12) Problem with reactor when using attached goal
Date Mon, 27 Mar 2006 06:59:11 GMT
     [ http://jira.codehaus.org/browse/MASSEMBLY-12?page=all ]

Vincent Massol updated MASSEMBLY-12:
------------------------------------

    Description: 
Here's my project dir structure:

{noformat}
trunk/
  |_ core/
    |_ api/
      |_ (several projects here)
    |_ uberjar/ (assembly project)
  |_ samples
    |_ testdata
      |_ empty-jar
      |_ (...)
{noformat}

If I build the trunk/core/ubjerjar project alone it works fine. Note: I have attached the
"attached" goal to the verify phase so the assembly can be created when calling "mvn install".

If I build the project from the trunk by typing "mvn install", the uberjar/ project fails
saying that the empty-jar artifact cannot be found in the local repository. That's normal
it cannot be found because there are no dependencies on it in the core/ branch and it hasn't
been built yet when the uberjar project executes. Of course there are no dependencies to it
in the uberjar project.

It seems there's something fishy happening in the assembly plugin implementation... :-)

Thanks

  was:
Here's my project dir structure:

trunk/
  |_ core/
    |_ api/
      |_ (several projects here)
    |_ uberjar/ (assembly project)
  |_ samples
    |_ testdata
      |_ empty-jar
      |_ (...)

If I build the trunk/core/ubjerjar project alone it works fine. Note: I have attached the
"attached" goal to the verify phase so the assembly can be created when calling "mvn install".

If I build the project from the trunk by typing "mvn install", the uberjar/ project fails
saying that the empty-jar artifact cannot be found in the local repository. That's normal
it cannot be found because there are no dependencies on it in the core/ branch and it hasn't
been built yet when the uberjar project executes. Of course there are no dependencies to it
in the uberjar project.

It seems there's something fishy happening in the assembly plugin implementation... :-)

Thanks


> Problem with reactor when using attached goal
> ---------------------------------------------
>
>          Key: MASSEMBLY-12
>          URL: http://jira.codehaus.org/browse/MASSEMBLY-12
>      Project: Maven 2.x Assembly Plugin
>         Type: Bug

>     Reporter: Vincent Massol
>      Fix For: 2.1

>
>
> Here's my project dir structure:
> {noformat}
> trunk/
>   |_ core/
>     |_ api/
>       |_ (several projects here)
>     |_ uberjar/ (assembly project)
>   |_ samples
>     |_ testdata
>       |_ empty-jar
>       |_ (...)
> {noformat}
> If I build the trunk/core/ubjerjar project alone it works fine. Note: I have attached
the "attached" goal to the verify phase so the assembly can be created when calling "mvn install".
> If I build the project from the trunk by typing "mvn install", the uberjar/ project fails
saying that the empty-jar artifact cannot be found in the local repository. That's normal
it cannot be found because there are no dependencies on it in the core/ branch and it hasn't
been built yet when the uberjar project executes. Of course there are no dependencies to it
in the uberjar project.
> It seems there's something fishy happening in the assembly plugin implementation... :-)
> Thanks

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message