maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allan Ramirez (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MASSEMBLY-20) Assembly doesn't work with provided scope
Date Thu, 09 Mar 2006 10:33:23 GMT
     [ http://jira.codehaus.org/browse/MASSEMBLY-20?page=all ]
     
Allan Ramirez closed MASSEMBLY-20:
----------------------------------

    Resolution: Fixed

-Fixed in SVN
-Created a scope artifact filter for assembly that can accept provided dependencies if the
scope tag in assembly descriptor is set to "provided"

> Assembly doesn't work with provided scope
> -----------------------------------------
>
>          Key: MASSEMBLY-20
>          URL: http://jira.codehaus.org/browse/MASSEMBLY-20
>      Project: Maven 2.x Assembly Plugin
>         Type: Bug

>  Environment: WinXP
>     Reporter: Brian Fox
>     Assignee: Allan Ramirez
>      Fix For: 2.1

>
> Original Estimate: 5 hours
>        Time Spent: 4 hours
>         Remaining: 1 hour
>
> I have a project with all dependancies in the provided scope. I'd like to create an assembly
that contains all these jars. If I set the scope to provided in the assembly descriptor xml
file, it ignores all these dependancies. If I change it to test, it grabs them, but also my
test dependancies as expected. 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message