maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abhijit Diwan (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MCHANGELOG-43) Changelog not getting created properly.
Date Wed, 09 Aug 2006 12:21:09 GMT
Changelog not getting created properly.
---------------------------------------

                 Key: MCHANGELOG-43
                 URL: http://jira.codehaus.org/browse/MCHANGELOG-43
             Project: Maven 2.x Changelog Plugin
          Issue Type: Bug
    Affects Versions: 2.0-beta-1
         Environment: Windows xp SP2 / maven 2.0.4
            Reporter: Abhijit Diwan


I am trying to generate change log for my maven project. 

I have following scm section under my pom.xml

    <scm>
        <connection>scm:perforce://EJB/ejb-dev/MavenCodeline/</connection>
    </scm>

and following plugin decalration under <reporting> section


            <plugin>
                <groupId>org.codehaus.mojo</groupId>
                <artifactId>changelog-maven-plugin</artifactId>
                <reportSets>
                    <reportSet>
                        <id>Perofrce report</id>
                        <configuration>
                            <type>range</type>
                            <range>10</range>
                            <repositoryConnection>
                                scm:perforce://EJB/ejb-dev/MavenCodeline/</repositoryConnection>
                            <properties>
                                <maven.changelog.factory>
                                    org.apache.maven.perforcelib.PerforceChangeLogFactory</maven.changelog.factory>
                            </properties>
                        </configuration>
                        <reports>
                            <report>changelog</report>
                            <report>file-activity</report>
                            <report>dev-activity</report>
                        </reports>
                    </reportSet>
                </reportSets>
            </plugin>


I have already defined P4PORT variable on my machine.

When I ran mvn site command from module directory AeConnector I get following error.

[INFO] Generating changed sets xml to: E:\views\EJB\ejb-dev\MavenCodeline\AeConn
ector\target\changelog.xml
[INFO] SCM Working Directory: E:\views\EJB\ejb-dev\MavenCodeline\AeConnector\src
\main\java
[INFO] SCM Command Line[0]: p4
[INFO] SCM Command Line[1]: filelog
[INFO] SCM Command Line[2]: -tl
[INFO] SCM Command Line[3]: //EJB/ejb-dev/MavenCodeline/AeConnector
[ERROR] //EJB/ejb-dev/MavenCodeline/AeConnector - no such file(s).

All my java code is under that directory but the plugin is not able to recurse all the subdirectories
under that directory. I looked at perforce doc and ran command "p4 filelog //EJB/ejb-dev/MavenCodeline/AeConnector/..."
and it worked so I think with plugin those last 3 dots which makes p4 recurse is not there.
The documentation for p4 command you can find from following url - (http://www.perforce.com/perforce/doc.051/manuals/cmdref/filelog.html)

Please please help.
thanks a lot
abhijit


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message