maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcel May (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MWAR-71) 2.0 works, 2.0-beta-2 does not
Date Wed, 23 Aug 2006 07:27:48 GMT
    [ http://jira.codehaus.org/browse/MWAR-71?page=comments#action_73086 ] 
            
Marcel May commented on MWAR-71:
--------------------------------

The cause of the different maven-war-plugin versions is a mystery ... I would expect mvn to
use the 2.0 version configured for simple-partial-update project, when building from the subproject
and from the  top since it is defined so in the subproject POM.. Maybe check what "mvn projecthelp\:effective-pom"
says for the top and for the subproject...

Sorry, can't build the source code since some deps are missing (javax.servlet.jsp:jsp-api),
and http://download.java.net/javaee5/external/shared repo is not accessible (from outside
of Sun I guess :-))

BTW, I recommend you use a central pluginManagement entry for plugin versions/defaul config
management, and a central dependencyManagement section. That way, you avoid spreading dependency
and plugin version configuration all over your POMs.
Like in you master pom, which already contains the compiler plugin. Maybe this will work for
your maven-war-plugin version problem at the moment, too.

> 2.0 works, 2.0-beta-2 does not
> ------------------------------
>
>                 Key: MWAR-71
>                 URL: http://jira.codehaus.org/browse/MWAR-71
>             Project: Maven 2.x War Plugin
>          Issue Type: Bug
>         Environment: Mac OS X
>            Reporter: Ed Burns
>         Attachments: code.bugreport.tar.gz
>
>
> I have a multi-module build.
> This is present in the build output when I do mvn from within the submodule
> [DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-war-plugin:2.0:war' -->
> [DEBUG]   (s) classesDirectory = /Users/edburns/Projects/J2EE/workareas/jsf-extensions-trunk/code/run-time/samples/simple-partial-update/target/classes
> [DEBUG]   (f) filters = []
> [DEBUG]   (f) outputDirectory = /Users/edburns/Projects/J2EE/workareas/jsf-extensions-trunk/code/run-time/samples/simple-partial-update/target
> [DEBUG]   (f) primaryArtifact = true
> [DEBUG]   (s) project = org.apache.maven.project.MavenProject@4146e221
> [DEBUG]   (f) warName = jsf-simple-partial-update
> [DEBUG]   (s) warSourceDirectory = /Users/edburns/Projects/J2EE/workareas/jsf-extensions-trunk/code/run-time/samples/simple-partial-update/src/main/webapp
> [DEBUG]   (s) directory = src/main/java
> [DEBUG]   (s) targetPath = WEB-INF
> [DEBUG]   (s) directory = /Users/edburns/Projects/J2EE/workareas/jsf-extensions-trunk/code/run-time/samples/simple-partial-update/../sunbrand/src/main/webapp
> [DEBUG]   (f) webResources = [Lorg.apache.maven.model.Resource;@392356
> [DEBUG]   (s) webappDirectory = /Users/edburns/Projects/J2EE/workareas/jsf-extensions-trunk/code/run-time/samples/simple-partial-update/target/jsf-simple-partial-update
> [DEBUG]   (f) workDirectory = /Users/edburns/Projects/J2EE/workareas/jsf-extensions-trunk/code/run-time/samples/simple-partial-update/target/war/work
> [DEBUG] -- end configuration --
> but this present when I run the build from the top level
> [DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-war-plugin:2.0-beta-2:war' -->
> [DEBUG]   (s) classesDirectory = /Users/edburns/Projects/J2EE/workareas/jsf-extensions-trunk/code/run-time/samples/simple-partial-update/target/classes
> [DEBUG]   (f) outputDirectory = /Users/edburns/Projects/J2EE/workareas/jsf-extensions-trunk/code/run-time/samples/simple-partial-update/target
> [DEBUG]   (s) project = org.apache.maven.project.MavenProject@4146e221
> [DEBUG]   (f) warName = jsf-simple-partial-update
> [DEBUG]   (s) warSourceDirectory = /Users/edburns/Projects/J2EE/workareas/jsf-extensions-trunk/code/run-time/samples/simple-partial-update/src/main/webapp
> [DEBUG]   (s) webappDirectory = /Users/edburns/Projects/J2EE/workareas/jsf-extensions-trunk/code/run-time/samples/simple-partial-update/target/jsf-simple-partial-update
> [DEBUG] -- end configuration --
> I would think the behaviour would be the same regardless of which
> version of the maven-war-plugin is pulled in.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message