maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aleksandr Tarutin (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MECLIPSE-179) Revise dependency configuration for WTP 1.5 EAR projects
Date Thu, 19 Oct 2006 21:21:21 GMT
Revise dependency configuration for WTP 1.5 EAR projects 
---------------------------------------------------------

                 Key: MECLIPSE-179
                 URL: http://jira.codehaus.org/browse/MECLIPSE-179
             Project: Maven 2.x Eclipse Plugin
          Issue Type: Improvement
          Components: WTP support
            Reporter: Aleksandr Tarutin
            Priority: Critical
             Fix For: 2.3


Dependencies for the WTP 1.5 EAR projects are correctly configured into 'J2EE Module Dependencies'.
That includes all of the artifacts from each project (EJB, WAR, Utility) that the EAR consists
of. But that's only part of the configuration. Next instead of adding the dependencies listed
in individual POMs to each project's classpath these dependencies should be selected on the
same 'J2EE Module Dependencies' configuration for the specific project. Then they will appear
under the 'EAR Libraries' entry in the project explorer. That way the EAR file built by WTP
1.5 will be much more consistent with the one built by maven.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message