maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephane Nicoll (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MWAR-69) Secondary artifacts aren't being attached
Date Sat, 17 Mar 2007 14:02:34 GMT

    [ http://jira.codehaus.org/browse/MWAR-69?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_90334
] 

Stephane Nicoll commented on MWAR-69:
-------------------------------------

Not sure it's still applicable. Did you set the classifier?

Can you please attach a sample project that reproduces the issue?

> Secondary artifacts aren't being attached
> -----------------------------------------
>
>                 Key: MWAR-69
>                 URL: http://jira.codehaus.org/browse/MWAR-69
>             Project: Maven 2.x War Plugin
>          Issue Type: Bug
>            Reporter: Jochen Wiedmann
>         Assigned To: Stephane Nicoll
>         Attachments: maven-secondary-artifact.patch
>
>
> If I do configure the maven-war-plugin to create a secondary artifact, then that artifact
isn't attached. I do believe, this is because the following code snippet is missing:
> Index: src/main/java/org/apache/maven/plugin/war/WarMojo.java
> ===================================================================
> --- src/main/java/org/apache/maven/plugin/war/WarMojo.java      (revision 433193)
> +++ src/main/java/org/apache/maven/plugin/war/WarMojo.java      (working copy)
> @@ -192,6 +192,10 @@
>              {
>                  artifact.setFile( warFile );
>              }
> +            else
> +            {
> +               projectHelper.attachArtifact( getProject(). "war", warFile );
> +            }
>          }
>      }
>  }

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message