maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukas Theussl (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MAVEN-1440) Clearing maven.repo.remote results in incorrect reporting of unsatisfied dependencies
Date Sun, 11 Mar 2007 19:51:34 GMT

     [ http://jira.codehaus.org/browse/MAVEN-1440?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lukas Theussl updated MAVEN-1440:
---------------------------------

    Fix Version/s:     (was: 1.1-rc1)

> Clearing maven.repo.remote results in incorrect reporting of unsatisfied dependencies
> -------------------------------------------------------------------------------------
>
>                 Key: MAVEN-1440
>                 URL: http://jira.codehaus.org/browse/MAVEN-1440
>             Project: Maven 1.x
>          Issue Type: Bug
>    Affects Versions: 1.0
>         Environment: Solaris
>            Reporter: Cameron Horn
>            Priority: Minor
>
> Running "maven -Dmaven.repo.remote= -Dmaven.mode.online=false"
> <snip>
> The use of the remote repository has been disabled. (x10)
> BUILD FAILED
> File...... /export/home/cruise/.maven/cache/maven-multiproject-plugin-1.3.1/plugin.jelly
> Element... maven:reactor
> Line...... 217
> Column.... 9
> The build cannot continue because of the following unsatisfied dependency:
> kernel-core-SNAPSHOT.jar
> </snip>
> Which is misleading. kernel-core-SNAPSHOT.jar failed to build because it was missing
dependencies.  Running "maven -o -Dmaven.repo.remote= multiproject:install-snapshot" shows
the correct dependencies:
> <snip>
> The use of the remote repository has been disabled. (x10)
> You are working offline so the build will continue, but kernel-core-SNAPSHOT.jar may
be out of date!
> You are working offline so the build will continue, but kernel-container-SNAPSHOT.jar
may be out of date!
> BUILD FAILED
> File...... /export/home/cruise/.maven/cache/maven-multiproject-plugin-1.3.1/plugin.jelly
> Element... maven:reactor
> Line...... 217
> Column.... 9
> The build cannot continue because of the following unsatisfied dependencies:
> commons-beanutils-1.6.1.jar
> commons-digester-1.4.1.jar
> </snip>

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message