maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jose CHILLAN (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (SUREFIRE-313) build fails with ClassNotFoundException, BUT the class IS there!
Date Tue, 05 Jun 2007 08:04:58 GMT

    [ http://jira.codehaus.org/browse/SUREFIRE-313?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_98414
] 

Jose CHILLAN commented on SUREFIRE-313:
---------------------------------------

Hi, 

I had the same issue but I solve it easily : surefire simply doesn't work if the full path
or the directory where your artifacts 
are contains non plain english chars. This is the case in your logs so just move your code
in a simple path (no space, only
standard ASCII char) and it will work.
Some other plugins have the same problem, such as docbook, and so on...


> build fails with ClassNotFoundException, BUT the class IS there!
> ----------------------------------------------------------------
>
>                 Key: SUREFIRE-313
>                 URL: http://jira.codehaus.org/browse/SUREFIRE-313
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: classloading, Junit 4.x support
>    Affects Versions: 2.3
>         Environment: Windows XP SP2, Java SE 6,  Maven 2.0.5
>            Reporter: Ivan Mikushin
>             Fix For: 2.4
>
>         Attachments: mvn-junit4.log, mvn-pojo-test.log, pom.xml
>
>
> JUnit 4 and POJO tests give ClassNotFoundException exceptions in *test* phase of the
build (pom.xml is attached). 
> The console output gives a hint: JUnit 3.8.1 is appended to the surefire-booter forked
JVM classpath instead of JUnit 4 (I tried it with junit-4.0, 4.1 and 4.2). When I try a POJO
test case I get the same error.
> Also attached are the outputs from the command lines for JUnit4 and POJO test cases
> {{mvn -X clean test > mvn.log}}

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message