maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MNG-1914) Wrong error message when using a mirror
Date Fri, 15 Jun 2007 14:36:59 GMT

     [ http://jira.codehaus.org/browse/MNG-1914?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Brett Porter updated MNG-1914:
------------------------------

    Component/s: Errors

> Wrong error message when using a mirror
> ---------------------------------------
>
>                 Key: MNG-1914
>                 URL: http://jira.codehaus.org/browse/MNG-1914
>             Project: Maven 2
>          Issue Type: Bug
>          Components: Errors
>    Affects Versions: 2.0.1
>            Reporter: Vincent Massol
>             Fix For: 2.1.x
>
>
> I had the following in my settings.xml:
> <settings>
> [...]
>   <mirrors>
>     <mirror>
>       <id>cargo m2 release repository</id>
>       <url>http://cargo.codehaus.org/dist2</url>
>       <mirrorOf>central</mirrorOf>
>    </mirror>
>   </mirrors>
>   <profiles>
>     <profile>
>       <id>staging-repo</id>
>       <repositories>
>         <repository>
>           <id>central</id>
> 	      <name>staging repo</name>
> 	      <url>http://test.maven.codehaus.org/maven2</url>
>           <releases>
>             <enabled>true</enabled>
>           </releases>
>           <snapshots>
>             <enabled>true</enabled>
>           </snapshots>
> 	    </repository>
>       </repositories>
>       <pluginRepositories>
>         <pluginRepository>
>           <id>central</id>
>           <name>staging repo</name>
> 	      <url>http://test.maven.codehaus.org/maven2</url>
>           <releases>
>             <enabled>true</enabled>
>           </releases>
>           <snapshots>
>             <enabled>true</enabled>
>           </snapshots>
> 	    </pluginRepository>
>       </pluginRepositories>
>     </profile>
>   </profiles>
>   <activeProfiles>
>     <activeProfile>staging-repo</activeProfile>
>   </activeProfiles>
> [...]
> </settings>
> When building any project I was getting the following console trace:
> [...]
> Downloading: http://cargo.codehaus.org/dist2/org/apache/maven/plugins/maven-plugin-parent/2.0/maven-plugin-parent-2.0.pom
> [WARNING] Unable to get resource from repository central (http://test.maven.codehaus.org/maven2)
> [INFO] ----------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ----------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
>  
> GroupId: org.apache.maven.plugins
> ArtifactId: maven-plugin-parent
> Version: 2.0
>  
> Reason: Unable to download the artifact from any repository
>  
>   org.apache.maven.plugins:maven-plugin-parent:pom:2.0
>  
> from the specified remote repositories:
>   central (http://test.maven.codehaus.org/maven2)
> As you can see it says that it cannot get the pom from the test.maven.codehaus.org repository
whereas it's actually looking in cargo.codehaus.org... The message needs  to be fixed.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message