maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "chuchi (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MECLIPSE-111) Additional webResources are not added to the component list when using WTP projects generation
Date Thu, 28 Jun 2007 14:56:14 GMT

    [ http://jira.codehaus.org/browse/MECLIPSE-111?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_100800
] 

chuchi commented on MECLIPSE-111:
---------------------------------

Please, please, please.... 

Can someone fix this, please?

Is very simple to add an xml tag like "webappDirectory" or simply apply the patch to maven
repository!!

> Additional webResources are not added to the component list when using WTP projects generation
> ----------------------------------------------------------------------------------------------
>
>                 Key: MECLIPSE-111
>                 URL: http://jira.codehaus.org/browse/MECLIPSE-111
>             Project: Maven 2.x Eclipse Plugin
>          Issue Type: Bug
>          Components: WTP support
>    Affects Versions: 2.2
>            Reporter: Renaud Julienne
>         Attachments: MECLIPSE-111-patch.txt
>
>
> I have a war project, with the standard layout :
>  + project
>     + src
>       + main
>         + java
>         + resources
>         + webapp
> But my project is also relying on a common web application framework, containing web
resources I must add to my project.
> So in the pom.xml, for the maven-war-plugin configuration, I have additional webResources
declared :
>   <plugin>
>     <artifactId>maven-war-plugin</artifactId>
>     <configuration>
>       <webResources>
>         <webResource>
>           <directory>${project.build.directory}/fwk</directory>
>         <webResource>
>       </webResources>
>     </configuration>
>   </plugin>
> When I generate the eclipse project, with WTP activated, the .component generated does
not include the wb-resource element corresponding to my webResource. It should contain :
>   <wb-resource deploy-path="/" source-path="target/fwk"/>

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message