maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stijn De Mulder (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MECLIPSE-132) "Class not found" when run/debug JUnit tests
Date Mon, 13 Aug 2007 08:30:47 GMT

    [ http://jira.codehaus.org/browse/MECLIPSE-132?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_104705
] 

Stijn De Mulder commented on MECLIPSE-132:
------------------------------------------

I've had the same issue. I checked the eclipse problems view for that project and apparently
there was a duplicate library on the build path.
After that i removed all the classpath entries that started with M2_REPO and now it works
fine. 

All the neccesary dependencies were already on the build path (under maven 2 dependencies)
so why are there extra build path entries?

Anyway that solved the problem for me.

> "Class not found" when run/debug JUnit tests
> --------------------------------------------
>
>                 Key: MECLIPSE-132
>                 URL: http://jira.codehaus.org/browse/MECLIPSE-132
>             Project: Maven 2.x Eclipse Plugin
>          Issue Type: Bug
>          Components: dependency resolution
>         Environment: gentoo linux 2006, kernel 2.6, sun-jdk-1.5.0.06, maven 2.0.4, eclipse
sdk 3.2, myeclipse 5 m2
>            Reporter: Diego Ballve
>         Attachments: maven-sample.zip
>
>
> This is for the behavior described in
> http://www.nabble.com/Keep-getting-%22Class-not-found%22-when-running-debugging-JUnit-tests-tf1851758.html#a5442440
> You get "Class not found" when running/debuging JUnit tests.
> For me it happened when I was importing another project and its dependencies (both m2
projects).
> Clean compile works fine, problem is with run.
> The workaround to get it working is:
> In the project containing your tests, edit Java Build Path | Order and Export: Make sure
M2 Dependencies appears BEFORE JRE System Library. 
> Thanks,
> Diego

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message