maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Piotr Tabor (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MEV-531) ant:ant:1.6.5 (completly wrong dependencies)
Date Sun, 12 Aug 2007 21:51:47 GMT

    [ http://jira.codehaus.org/browse/MEV-531?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_104680
] 

Piotr Tabor commented on MEV-531:
---------------------------------

Proofs (to make commiter's live easier): 
* exists: http://mirrors.ibiblio.org/pub/mirrors/maven2/xerces/xercesImpl/2.6.2
* doesn't exist: http://mirrors.ibiblio.org/pub/mirrors/maven2/xerces/xerces-impl

* exists: http://mirrors.ibiblio.org/pub/mirrors/maven2/xml-apis/xml-apis/1.3.4
* doesn't exist: http://mirrors.ibiblio.org/pub/mirrors/maven2/xml-apis/xml-apis/2.6.2

Link to official ant distribution: http://archive.apache.org/dist/ant/binaries/apache-ant-1.6.5-bin.zip

> ant:ant:1.6.5 (completly wrong dependencies)
> --------------------------------------------
>
>                 Key: MEV-531
>                 URL: http://jira.codehaus.org/browse/MEV-531
>             Project: Maven Evangelism
>          Issue Type: Bug
>          Components: Dependencies
>            Reporter: Piotr Tabor
>
> Current ant:ant pom is: 
> <project>
>   <modelVersion>4.0.0</modelVersion>
>   <groupId>ant</groupId>
>   <artifactId>ant</artifactId>
>   <version>1.6.5</version>
>   <dependencies>
>     <dependency>
>       <groupId>xerces</groupId>
>       *<artifactId>xerces-impl</artifactId>* 
>       <version>2.6.2</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>xml-apis</groupId>
>       <artifactId>xml-apis</artifactId>
>       *<version>2.6.2</version>*
>       <optional>true</optional>
>     </dependency>
>   </dependencies>
> </project>
> Instead of: <artifactId>xerces-impl</artifactId> should be <artifactId>xercesImpl</artifactId>
(xerces-impl does not exist in repo)
> And the version of xml-apis should be: 1.3.04 (2.6.2 does not exist)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message