maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Casey (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MANTLR-24) allow (force?) users to define the antlr artifact to use (w/ patch)
Date Thu, 06 Dec 2007 17:06:57 GMT

     [ http://jira.codehaus.org/browse/MANTLR-24?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

John Casey closed MANTLR-24.
----------------------------

         Assignee: John Casey
       Resolution: Fixed
    Fix Version/s: 2.0

Patch applied. Thanks.

> allow (force?) users to define the antlr artifact to use (w/ patch)
> -------------------------------------------------------------------
>
>                 Key: MANTLR-24
>                 URL: http://jira.codehaus.org/browse/MANTLR-24
>             Project: Maven 2.x Antlr Plugin
>          Issue Type: Improvement
>            Reporter: Steve Ebersole
>            Assignee: John Casey
>             Fix For: 2.0
>
>         Attachments: MANTLR-24.patch
>
>
> Currently (through 2.0.8) there is a problem where users cannot override the version
of Antlr used by this plugin to generate the grammars.  This seem to be fixed for 2.1 (based
on a local snapshot I have), however...
> I discussed this with John Casey on IRC, and he made a really valid point that there
does not seem like there is a scenario where it would be valid for the project itself to not
have a dependency on Antlr.  So that perhaps it made sense for the plugin to: 1) enforce that
and 2) just pick up and use the Antlr dependency artifact from the project.
> I have created a patch which does just that for you consideration.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message