maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Herve Boutemy (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MSITE-130) Site generation fails for site.xml in UTF8 with BOM
Date Sat, 01 Dec 2007 12:07:58 GMT

     [ http://jira.codehaus.org/browse/MSITE-130?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Herve Boutemy closed MSITE-130.
-------------------------------

         Assignee: Herve Boutemy
       Resolution: Fixed
    Fix Version/s:     (was: 2.0-beta-7)
                   2.0-beta-6

XML encoding support is fixed for site.xml and every xdoc file, fml, and so on
to be precise, BOM is supported for UTF-8 and UTF-16, but not UTF-32

> Site generation fails for site.xml in UTF8 with BOM
> ---------------------------------------------------
>
>                 Key: MSITE-130
>                 URL: http://jira.codehaus.org/browse/MSITE-130
>             Project: Maven 2.x Site Plugin
>          Issue Type: Improvement
>          Components: encoding
>            Reporter: Shinobu Kawai
>            Assignee: Herve Boutemy
>            Priority: Critical
>             Fix For: 2.0-beta-6
>
>
> I get the following error if I edit site.xml with Windows Notepad.
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Error during page generation
> Embedded error: Can't read site descriptor.
> only whitespace content allowed before start tag and not \uef (position: START_DOCUMENT
seen \uef... @1:1) 
> This is due to http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4508058 .  Since Sun
is saying they won't fix this "RFE" (which I think is a bug), we need a workaround.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message