maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Herve Boutemy (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MANTTASKS-91) [task dependencies]Trouble between mvn and manttasks
Date Sun, 02 Dec 2007 22:55:58 GMT

     [ http://jira.codehaus.org/browse/MANTTASKS-91?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Herve Boutemy closed MANTTASKS-91.
----------------------------------

         Assignee: Herve Boutemy
       Resolution: Fixed
    Fix Version/s: 2.0.8

added ProfileManager use, which fixes resolution bug

> [task dependencies]Trouble between mvn and manttasks
> ----------------------------------------------------
>
>                 Key: MANTTASKS-91
>                 URL: http://jira.codehaus.org/browse/MANTTASKS-91
>             Project: Maven 2.x Ant Tasks
>          Issue Type: Bug
>          Components: dependencies task
>    Affects Versions: 2.0.7
>         Environment: Windows 2000/XP
> Java version: 1.4.2_03
> Ant 1.6.5
>            Reporter: David N'DIAYE
>            Assignee: Herve Boutemy
>             Fix For: 2.0.8
>
>         Attachments: testDependency.zip
>
>
> I have a library {{org.test.b}}.
> * In the first version i declare i have a dependency with the library {{org.test:d:1.1}}
> * In the second version i declare i have no dependencies
> My current developpement use the library {{org.test.a}} which have a dependency with
{{org.test:b:1.0}}.
> I declare i prefered to use the new library {{org.test:b:1.1}}
> and i have another library {{org.test:c}} because of its dependency, it must use the
library {{org.test:d}}
> If i write my pom like this :
> {code:xml}<dependencies>
>   <dependency>
>     <groupId>org.test</groupId>
>     <artifactId>a</artifactId>
>     <version>1.0</version>
>   </dependency>
>   <dependency>
>     <groupId>org.test</groupId>
>     <artifactId>c</artifactId>
>     <version>1.0</version>
>   </dependency>
>   <dependency>
>     <groupId>org.test</groupId>
>     <artifactId>b</artifactId>
>     <version>1.1</version>
>   </dependency>
> </dependencies>
> {code} 
> When I run ant with this pom :
> {code:xml}
> <artifact:pom id="pom" file="pom.xml" />
> <artifact:remoteRepository id="repository" url="file:./repository" />
> <artifact:dependencies filesetId="compile.dependency.fileset" useScope="compile" verbose="true">
>     <pom refid="pom" />
>     <remoteRepository refid="repository" />
>     <localRepository path="./localRepository" />
> </artifact:dependencies>
> {code}
> *{color:red}the dependency fileset does not contain the library {{org.test:d}}{color}*
> And when i run *{{mvn site:site}}*, {color:green}i have {{org.test:d:1.2}} in the scope
compile{color}.
> -----
> here, you can find the dependency tree of my testcase
> {noformat}
> test:test-tree:jar:1.0 (selected)
>   org.test:a:jar:1.0:compile (selected)
>     org.test:b:jar:1.0:compile (selected)
>       org.test:d:jar:1.1:compile (selected)
>   org.test:c:jar:1.0:compile (selected)
>     org.test:e:jar:1.0:compile (selected)
>       org.test:d:jar:1.2:compile (removed - nearer found: 1.1)
>   org.test:b:jar:1.0:compile (removed - nearer found: 1.1)
>   org.test:b:jar:1.1:compile (selected)
> {noformat}
> ----
> To run my testcase you can do :
> * {{ant clean}} :  to remove all generated
> * {{ant test}} : to check the problem
> And you run maven (2.0.7) like this :
> * {{mvn -s settings.xml site:site}}

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message