maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Raible (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (ARCHETYPE-127) New Version is not backwards compatible - prompts for version and package when they should be read from archetype
Date Tue, 12 Feb 2008 04:06:29 GMT
New Version is not backwards compatible - prompts for version and package when they should
be read from archetype
-----------------------------------------------------------------------------------------------------------------

                 Key: ARCHETYPE-127
                 URL: http://jira.codehaus.org/browse/ARCHETYPE-127
             Project: Maven Archetype
          Issue Type: Bug
    Affects Versions: 2.0-alpha-1
         Environment: Maven 2.0.8, OS X, Java 5
            Reporter: Matt Raible


This new version of the archetype plugin breaks compatibility with the old version. It prompts
me for both version and package. It should default both of these values to what's specified
in the archetype (1.0-SNAPSHOT and war). Try any of the "archetype:create" on the AppFuse
QuickStart to reproduce.

http://appfuse.org/display/APF/AppFuse+QuickStart

These commands worked fine (no prompting) with the old version. For example:

mvn archetype:create -DarchetypeGroupId=org.appfuse.archetypes -DarchetypeArtifactId=appfuse-basic-spring
-DremoteRepositories=http://static.appfuse.org/releases -DarchetypeVersion=2.0.1 -DgroupId=com.mycompany.app
-DartifactId=myproject

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message